Routing

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  MPLS Static-LSP

    Posted 01-19-2022 20:11
    In the topology below  PE1's loopback address, 1.1.1.1 is able to ping PE2's 6.6.6.6. Both PE1 and PE2 are pushing labels to their next-hop LSR's. The LSR routers then transit the labels and swap them on each hop until reaching the PHP and popping the label before PE1 and PE2.

    My question is why can I ping the loopback address, but when I traceroute I only see the following... (I am seeing packet loss on the pings) this lab is also in EVE-NG using vMX routers.

    root@PE1> ping 6.6.6.6 source 1.1.1.1
    PING 6.6.6.6 (6.6.6.6): 56 data bytes
    64 bytes from 6.6.6.6: icmp_seq=0 ttl=60 time=954.641 ms
    64 bytes from 6.6.6.6: icmp_seq=1 ttl=60 time=106.520 ms
    64 bytes from 6.6.6.6: icmp_seq=2 ttl=60 time=14.163 ms
    64 bytes from 6.6.6.6: icmp_seq=3 ttl=60 time=12.555 ms
    64 bytes from 6.6.6.6: icmp_seq=4 ttl=60 time=31.292 ms
    64 bytes from 6.6.6.6: icmp_seq=5 ttl=60 time=35.440 ms
    64 bytes from 6.6.6.6: icmp_seq=6 ttl=60 time=2059.133 ms
    64 bytes from 6.6.6.6: icmp_seq=7 ttl=60 time=1060.578 ms
    64 bytes from 6.6.6.6: icmp_seq=8 ttl=60 time=109.648 ms
    64 bytes from 6.6.6.6: icmp_seq=9 ttl=60 time=964.152 ms
    ^C
    --- 6.6.6.6 ping statistics ---
    11 packets transmitted, 10 packets received, 9% packet loss
    round-trip min/avg/max/stddev = 12.555/534.812/2059.133/661.174 ms
    
    root@PE1> traceroute 6.6.6.6 no-resolve source 1.1.1.1
    traceroute to 6.6.6.6 (6.6.6.6) from 1.1.1.1, 30 hops max, 52 byte packets
     1  * * *
     2  * * *
     3  * * *
     4  * *^C
    ​




    Any help appreciated. thanks.

    ------------------------------
    Jack
    ------------------------------


  • 2.  RE: MPLS Static-LSP
    Best Answer

    Posted 01-20-2022 10:12
    Hi Jack, 

    if i have to guess, the normal ping is using inet.0 while your traceroute is not, try enabling ICMP tunneling on your LSRs, that should allow the ICMP traffic to be send through the LSP and see each one of the labels in the path. 

    set protocols mpls icmp-tunneling

    Thanks
    Gabriel F.V

    ------------------------------
    GABRIEL FLORES
    ------------------------------