Routing

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  inter-Provider L3 VPN label question

    Posted 03-30-2022 05:31
    I am doing the following lab from Juniper
    CE1 sends icmp to CE2. when the packet leaves ASBR1 towards ASBR2, how many  labels should I see  ?
    I saw 3 labels when the packet leaves PE1, 2 labels when the packet leaves P1.
    I configured the following in ASBR1
    set interfaces ge-0/0/1 unit 0 family inet address 192.168.4.24/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces ge-0/0/3 unit 0 family inet address 192.168.3.24/24
    set interfaces ge-0/0/3 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 192.0.200.24/32
    set interfaces lo0 unit 0 family iso address 49.0000.0192.0000.0200.0024.00
    set routing-options router-id 192.0.200.24
    set routing-options route-distinguisher-id 192.0.200.24
    set routing-options autonomous-system 200
    set protocols rsvp interface ge-0/0/1.0
    set protocols rsvp interface lo0.0
    set protocols mpls label-switched-path To-PE2 to 192.0.200.22
    set protocols mpls interface ge-0/0/1.0
    set protocols bgp group To-PE2 type internal
    set protocols bgp group To-PE2 local-address 192.0.200.24
    set protocols bgp group To-PE2 family inet labeled-unicast
    set protocols bgp group To-PE2 export NHS
    set protocols bgp group To-PE2 neighbor 192.0.200.22
    set protocols bgp group To-ASBR1 type external
    set protocols bgp group To-ASBR1 family inet labeled-unicast
    set protocols bgp group To-ASBR1 export exp2ASBR1
    set protocols bgp group To-ASBR1 neighbor 192.168.3.14 peer-as 100
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set policy-options policy-statement NHS then next-hop self
    set policy-options policy-statement exp2ASBR1 term 1 from protocol ospf
    set policy-options policy-statement exp2ASBR1 term 1 from route-filter 192.0.200.22/32 exact
    set policy-options policy-statement exp2ASBR1 term 1 then accept
    ​

    labeled-unicast should add one more label when sending the packet to ASBR2, Right ?

    But I saw only two labels. So ASBR2 popped 1 label. and then P2 popped another label. when the packet reached PE2 without any Label. PE2 does not know which VRF the packet should go, so ping failed.
    I sniffed the packet hop by hop.
    What did I miss here ?

    thanks !!



  • 2.  RE: inter-Provider L3 VPN label question

    Posted 03-30-2022 14:05
    I got one set of configuration working.  After I captured the traffic on each device, I noticed ASBR2 swap instead of pop. So I had something wrong in the previous configuration. checking now.

    This is  from the working one.


  • 3.  RE: inter-Provider L3 VPN label question

    Posted 03-31-2022 15:09
    Got it working. I need to move  rsvp routes in inet.3 to inet.0  via 

    set protocols mpls traffic-engineering bgp-igp-both-ribs