Routing

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  ntp associations stuck in INIT but can set date via CLI

    Posted 04-04-2022 13:24

    I can successfully  set NTP date via CLI:

    > set date ntp time-a-g.nist.gov
     4 Apr 09:54:26 ntpdate[56888]: step time server 129.6.15.28 offset -0.013953 sec

    But when I add the same server in the configuration

    > show host time-a-g.nist.gov
    time-a-g.nist.gov has address 129.6.15.28
    
    {master:0}
    
    > show configuration system ntp
    server 129.6.15.28;
    server 128.138.140.44;
    
    {master:0}

    the NTP daemon gets stuck in the INIT state:

    > show ntp associations
         remote           refid      st t when poll reach   delay   offset  jitter
    ==============================================================================
     time-a-g.nist.g .INIT.          16 -    -  512    0    0.000    0.000 4000.00
     india.colorado. .INIT.          16 -    -  512    0    0.000    0.000 4000.00
    
    {master:0}

    If I had a firewall issue, I would expect set date ntp to give me timeout. I am confused why it's stuck.



  • 2.  RE: ntp associations stuck in INIT but can set date via CLI

     
    Posted 04-05-2022 09:55
    Hi,
    it might be that 'set date ntp ...' uses an unprivileged source port. So you could have a firewall issue after all.
    You should be able to confirm with monitor traffic | Junos OS | Juniper Networks
    Regards
    Ulf