Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Ex4300 trunk to HP Procurve

    Posted 02-24-2022 13:57
    I have been trying to set up a trunk between these 2 for days and I don't understand what is going on. It looks like I can ping the HP through my me0 interface, I can ping 8.8.8.8. I have a laptop now connected to ge-0/0/0 and it is not getting an IP address, I have the juniper trunk at port 46 and connected to port 32 on the HP. So I feel that the trunk configuration is missing something. The sad part is I'm brand new to Juniper and HP:

    Juniper config:

    {master:0}[edit]
    Net_Admin# run show configuration
    ## Last commit: 2022-02-24 10:18:03 PST by Net_Admin
    version 21.4R1.12;
    system {
    root-authentication {
    encrypted-password "$6$UcjZYYL6$FwdbkVuj3S/ipz1EuJM7eUb6vHraepH4jLNWw0SuLA5JjWvPptNVSadoYC/6naWFwd2i28hZgkmtCrE.gx37A1"; ## SECRET-DATA
    }
    login {
    user Net_Admin {
    uid 2005;
    class super-user;
    authentication {
    encrypted-password "$6$gutP9p40$1Qw94F4qX0f9kQyHBOcyvr5LIOjipUzaq2l1FNy9urG9Lqo9uA8xztpHVoQZF/XeCxfTfNL0Wi3sYHwofOeFn."; ## SECRET-DATA
    }
    }
    }
    services {
    ssh {
    root-login allow;
    protocol-version v2;
    max-sessions-per-connection 3;
    ciphers aes256-cbc;
    macs hmac-sha2-256;
    key-exchange dh-group14-sha1;
    client-alive-count-max 10;
    client-alive-interval 10;
    hostkey-algorithm {
    ssh-rsa;
    }
    connection-limit 3;
    rate-limit 200;
    }
    netconf {
    ssh;
    rfc-compliant;
    yang-compliant;
    }
    web-management {
    https {
    system-generated-certificate;
    interface me0.0;
    }
    }
    }
    auto-snapshot;
    name-server {
    192.168.15.100;
    }
    syslog {
    file interactive-commands {
    interactive-commands any;
    }
    file messages {
    any notice;
    authorization info;
    }
    }
    phone-home {
    server https://redirect.juniper.net;
    rfc-compliant;
    }
    }
    interfaces {
    ge-0/0/0 {
    unit 0 {
    family ethernet-switching {
    vlan {
    members Workstations;
    }
    }
    }
    }
    ge-0/0/1 {
    unit 0 {
    family ethernet-switching {
    vlan {
    members Workstations;
    }
    storm-control default;
    }
    }
    }
    ge-0/0/2 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/3 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/4 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/5 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/6 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/7 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/8 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/9 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/10 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/11 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/12 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/13 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/14 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/15 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/16 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/17 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/18 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/19 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/20 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/21 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/22 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/23 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/24 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/25 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/26 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/27 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/28 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/29 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/30 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/31 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/32 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/33 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/34 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/35 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/36 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/37 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/38 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/39 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/40 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/41 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/42 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/43 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/44 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/45 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/0/46 {
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members all;
    }
    storm-control default;
    }
    }
    }
    ge-0/0/47 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/2/0 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    xe-0/2/0 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/2/1 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    xe-0/2/1 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/2/2 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    xe-0/2/2 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    ge-0/2/3 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    xe-0/2/3 {
    unit 0 {
    family ethernet-switching {
    storm-control default;
    }
    }
    }
    irb {
    unit 0 {
    family inet {
    dhcp;
    }
    }
    unit 1 {
    family inet {
    address 192.168.2.22/23;
    }
    }
    }
    me0 {
    unit 0 {
    family inet {
    address 192.168.2.10/23;
    }
    }
    }
    vme {
    unit 0;
    }
    }
    forwarding-options {
    storm-control-profiles default {
    all;
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop [ 192.168.2.218 192.168.2.1 ];
    }
    }
    protocols {
    lldp {
    interface all;
    }
    lldp-med {
    interface all;
    }
    igmp-snooping {
    vlan default;
    }
    rstp {
    interface all;
    }
    }
    poe {
    interface all;
    }
    vlans {
    Servers {
    vlan-id 15;
    }
    Workstations {
    vlan-id 2;
    l3-interface irb.1;
    }
    default {
    vlan-id 1;
    l3-interface irb.0;
    }
    }

    HP Config:
     
    hostname "AVTA-SW-8"
    time timezone -480
    time daylight-time-rule Continental-US-and-Canada
    module 1 type J9148A
    interface 1
    poe-lldp-detect enabled
    exit
    interface 2
    poe-lldp-detect enabled
    exit
    interface 3
    poe-lldp-detect enabled
    exit
    interface 4
    poe-lldp-detect enabled
    exit
    interface 5
    poe-lldp-detect enabled
    exit
    interface 6
    poe-lldp-detect enabled
    exit
    interface 7
    poe-lldp-detect enabled
    exit
    interface 8
    poe-lldp-detect enabled
    exit
    interface 9
    poe-lldp-detect enabled
    exit
    interface 10
    poe-lldp-detect enabled
    exit
    interface 11
    poe-lldp-detect enabled
    exit
    interface 12
    poe-lldp-detect enabled
    exit
    interface 13
    poe-lldp-detect enabled
    exit
    interface 14
    poe-lldp-detect enabled
    exit
    interface 15
    poe-lldp-detect enabled
    exit
    interface 16
    poe-lldp-detect enabled
    exit
    interface 17
    poe-lldp-detect enabled
    exit
    interface 18
    poe-lldp-detect enabled
    exit
    interface 19
    name "Access_Paratransit_Interface"
    poe-lldp-detect enabled
    exit
    interface 20
    poe-lldp-detect enabled
    exit
    interface 21
    poe-lldp-detect enabled
    exit
    interface 22
    poe-lldp-detect enabled
    exit
    interface 23
    poe-lldp-detect enabled
    exit
    interface 24
    poe-lldp-detect enabled
    exit
    interface 25
    poe-lldp-detect enabled
    exit
    interface 26
    poe-lldp-detect enabled
    exit
    interface 27
    poe-lldp-detect enabled
    exit
    interface 28
    poe-lldp-detect enabled
    exit
    interface 29
    poe-lldp-detect enabled
    exit
    interface 30
    poe-lldp-detect enabled
    exit
    interface 31
    poe-lldp-detect enabled
    exit
    interface 32
    poe-lldp-detect enabled
    exit
    interface 33
    poe-lldp-detect enabled
    exit
    interface 34
    poe-lldp-detect enabled
    exit
    interface 35
    poe-lldp-detect enabled
    exit
    interface 36
    poe-lldp-detect enabled
    exit
    interface 37
    poe-lldp-detect enabled
    exit
    interface 38
    poe-lldp-detect enabled
    exit
    interface 39
    poe-lldp-detect enabled
    exit
    interface 40
    poe-lldp-detect enabled
    exit
    interface 41
    poe-lldp-detect enabled
    exit
    interface 42
    poe-lldp-detect enabled
    exit
    interface 43
    poe-lldp-detect enabled
    exit
    interface 44
    poe-lldp-detect enabled
    exit
    interface 46
    name "AP_Corner_Lt_Pole_Low"
    exit
    interface 48
    name "AP_Corner_Lt_Pole_High"
    exit
    trunk 45,47 Trk1 LACP
    ip default-gateway 192.168.2.1
    vlan 1
    name "DEFAULT_VLAN"
    ip address 192.168.1.12 255.255.255.0
    no untagged 1-44,46,48,Trk1
    exit
    vlan 2
    name "INSIDE"
    untagged 3-6,8-13,20-30,32-44,Trk1
    ip helper-address 192.168.2.224
    ip address 192.168.2.218 255.255.254.0
    tagged 1
    jumbo
    ip igmp
    exit
    vlan 10
    name "VOICE"
    untagged 7
    qos priority 6
    ip helper-address 192.168.10.5
    tagged 1-6,8-44,Trk1
    voice
    no ip address
    jumbo
    ip igmp
    exit
    vlan 15
    name "SERVERS"
    tagged 23,43,Trk1
    no ip address
    exit
    vlan 20
    name "DATA"
    tagged Trk1
    no ip address
    exit
    vlan 25
    name "WIRELESS"
    untagged 46,48
    tagged Trk1
    no ip address
    exit
    vlan 26
    name "BUS-VIDEO-WIRELESS"
    tagged 36,46,48,Trk1
    no ip address
    exit
    vlan 27
    name "WIRELESS-DATA"
    tagged 36,46,48,Trk1
    no ip address
    exit
    vlan 30
    name "VLAN30"
    tagged Trk1
    no ip address
    exit
    vlan 35
    name "SECURITY"
    tagged Trk1
    no ip address
    exit
    vlan 40
    name "SECURITY-BADGE"
    untagged 2
    tagged Trk1
    no ip address
    exit
    vlan 45
    name "CONTRACTOR"
    tagged Trk1
    no ip address
    exit
    vlan 172
    name "GUEST"
    untagged 14-19
    tagged 36,46,48,Trk1
    no ip address
    exit
    vlan 222
    name "AV-SYSTEMS"
    tagged 1,36
    no ip address
    exit
    vlan 28
    name "GENERAL2-WLAN"
    tagged 36,46,48,Trk1
    no ip address
    exit
    vlan 254
    name "HAMS-WIRELESS"
    tagged 46,48,Trk1
    no ip address
    exit
    vlan 127
    name "AVTA_Internal_WiFi"
    tagged 36,46,48,Trk1
    no ip address
    exit
    vlan 140
    name "AVTA_Computers"
    untagged 31
    tagged Trk1
    no ip address
    exit
    vlan 110
    name "DMZ"
    tagged Trk1
    no ip address
    exit
    fault-finder bad-driver sensitivity high
    fault-finder bad-transceiver sensitivity high
    fault-finder bad-cable sensitivity high
    fault-finder too-long-cable sensitivity high
    fault-finder over-bandwidth sensitivity high
    fault-finder broadcast-storm sensitivity high
    fault-finder loss-of-link sensitivity high
    fault-finder duplex-mismatch-HDx sensitivity high
    fault-finder duplex-mismatch-FDx sensitivity high
    qos type-of-service diff-services
    sflow 1 destination 192.168.15.232 9999
    sflow 1 polling 1-44 30
    sflow 1 sampling 1-44 128
    timesync sntp
    sntp unicast
    sntp server priority 1 192.168.2.5 3
    web-management ssl
    snmp-server community "public" unrestricted
    spanning-tree
    spanning-tree 3 admin-edge-port
    spanning-tree 3 bpdu-protection
    spanning-tree 5 admin-edge-port
    spanning-tree 5 bpdu-protection
    spanning-tree 6 admin-edge-port
    spanning-tree 6 bpdu-protection
    spanning-tree 8 admin-edge-port
    spanning-tree 8 bpdu-protection
    spanning-tree 10 admin-edge-port
    spanning-tree 10 bpdu-protection
    spanning-tree 15 admin-edge-port
    spanning-tree 31 admin-edge-port
    spanning-tree 31 bpdu-protection
    spanning-tree 33 admin-edge-port
    spanning-tree 43 admin-edge-port
    spanning-tree 46 bpdu-filter
    spanning-tree 48 bpdu-filter
    spanning-tree Trk1 priority 4
    spanning-tree config-name "MSTP1"
    spanning-tree config-revision 1
    spanning-tree instance 1 vlan 2-254
    spanning-tree instance 1 priority 9
    spanning-tree instance 1 Trk1 priority 4
    spanning-tree priority 9
    primary-vlan 2
    no autorun
    password manager




  • 2.  RE: Ex4300 trunk to HP Procurve

    Posted 02-25-2022 11:16
    Maybe I'm missing it but port 32 on the HP doesn't seem to have any vlan trunking configured. At least in the Aruba (which HPE now uses for their switches) world I think you need to define the trunking options? Looking at the vlans it doesn't show it as a tagged interface either. The Juniper side looks correct enough.

    ------------------------------
    Allyn Crowe
    ------------------------------



  • 3.  RE: Ex4300 trunk to HP Procurve

    Posted 02-25-2022 16:46
    Trunks are not the same on the HP as you would normally think of a trunk. They are aggregate etherernet/etherchannel. 

    You just need to tag what VLANs you want on port 32 on the HP side. 

    vlan 10 on the config you shared looks like it is tagged for port 32. 

    Here is a handy HP command:

    # show vlan ports 2/a4 detail

     Status and Counters - VLAN Information - for ports 2/A4

      VLAN ID Name                 | Status     Voice Jumbo Mode
      ------- -------------------- + ---------- ----- ----- --------
      1       DEFAULT_VLAN            | Port-based No    No    Untagged
      100     voice                            | Port-based Yes   No    Tagged
      200     service                         | Port-based No    No    Tagged
      300     pci                                 | Port-based No    No    Tagged
      400     wired                            | Port-based No    No    Tagged
      1002    Firewall_Untrusted   | Port-based No    No    Tagged



    -Jim