Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Disconnects and slow performance to ADP website

  • 1.  Disconnects and slow performance to ADP website

    Posted 02-16-2022 14:33
    Dear Juniper community..

    Wanting to get some extra eyeballs on a connectivity issue to the ADP website from one of our clients here on campus. The client will randomly get disconnected from ADP, and sometimes has trouble logging in or pages not loading or loading slowly. A trace to workforcenow.adp.com shows a good deal of latency (non responding routers) near the ADP end of the trace. I'm seeing a pretty healthy number of Dup ACKs and out of order packets in Wireshark traces taken from our Palo firewall. I can provide those should somebody be willing to take a look. I know dup aks are not the end of the work, so I'm questioning their impact here...and hoping somebody can shed some light on this for us. I plan to reach out to ADP as well.  Trace route from client below w 4th line scrubbed....

    I should mention that I checked all interfaces from client to access switch (EX3400) to core (EX4600) to firewall etc - no interface errors - that all looks healthy.

    Thanks much ...Dennis 

    I was also concerned about the response from our core (EX4600) (line 2) - it's pretty ugly ping times (at times)- although no performance issues -other than the client above - cpu and memory are very healthy, and no interface errors. I also stumbled on this article which says to basically ignore icmp for performance stats. 

    Tracing route to workforcenow.adp.com [170.146.102.193]
    over a maximum of 30 hops:

      1   5 ms   5 ms   4 ms 10.7.10.1
      2   196 ms   30 ms   43 ms 10.1.1.33
      3   <1 ms   <1 ms   <1 ms captive.haverford.local [10.1.1.6]
      4   1 ms   1 ms   1 ms p113.216_162_95.mciu.k12.pa.us [xxx.xxx.95.113]
      5   2 ms   2 ms   2 ms be6575.nr51.b003003-4.phl03.atlas.cogentco.com [38.104.115.153]
      6   2 ms   2 ms   2 ms be2326.rcr21.phl03.atlas.cogentco.com [154.24.67.234]
      7   2 ms   2 ms   2 ms be3163.rcr21.phl01.atlas.cogentco.com [154.54.7.1]
      8   5 ms   5 ms   4 ms be2364.ccr41.jfk02.atlas.cogentco.com [154.54.3.141]
      9   5 ms   5 ms   5 ms be3495.ccr31.jfk10.atlas.cogentco.com [66.28.4.182]
    10   *       *       *   Request timed out.
    11   6 ms   10 ms   7 ms ae16.cs1.lga5.us.zip.zayo.com [64.125.25.56]
    12   9 ms   8 ms   10 ms ae13.er3.lga5.us.zip.zayo.com [64.125.27.45]
    13   5 ms   4 ms   5 ms 208.184.23.222.ipyx-143212-001-zyo.zip.zayo.com [208.184.23.222]
    14   7 ms   5 ms   5 ms po110.bs-a.sech-lga.netarch.akamai.com [23.57.97.243]
    15   *       *       *   Request timed out.
    16   5 ms   4 ms   5 ms ae120.access-a.sech-lga.netarch.akamai.com [23.57.97.249]
    17   5 ms   5 ms   5 ms 93.191.172.154
    18   49 ms   49 ms   49 ms a69-192-173-50.deploy.static.akamaitechnologies.com [69.192.173.50]
    19   *       *       *   Request timed out.
    20   *       *       *   Request timed out.
    21   *       *       *   Request timed out.
    22   *       *       *   Request timed out.
    23   50 ms   50 ms   50 ms workforcenow.adp.com [170.146.102.193]