Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  ERPS configuration issues

    Posted 05-05-2022 05:36

    Hello all,

    We are trying to setup ring of 5 QFX switches, 4 of them QFX5200 JunOS 18.3R2-S2.1 and 1 QFX10002-72Q JunOS 18.4R2-S3.

    We follow Juniper web site tutorial.

    QFX10002 is the ring-protection-link-owner.

    Everything starts normal but when we disconnect any line between two QFX5200 in the ring, QFX10002 does not detect that the ring is broken.

    QFX10002 detects that ring is broken only when link directly connected to it is disconnected.

    In order to bring it back to idle state, directly connected link have to be disconnected.



    ------------------------------
    Nikolay Mladenov
    ------------------------------


  • 2.  RE: ERPS configuration issues

    Posted 05-06-2022 08:23
    Hello all,

    To add some more info to the issue. In the log of QFX10002 we get the following messages:

    =======================================

    May 5 09:57:59 Main_DC_Sofia fpc0 expr_dfw_check_match:1067 L2 filter erp-bd-filter--5 has invalid match conditions.
    May 5 09:57:59 Main_DC_Sofia fpc0 expr_dfw_check_match (): L2 filter erp-bd-filter--5 has invalid match conditions. Please re-config.
    May 5 09:57:59 Main_DC_Sofia fpc0 expr_dfw_chip_get_flt_type:1162 expr_dfw_chip_get_flt_type (): get L2 filter resolve type for erp-bd-filter--5. Need to re-config the L2 filter.
    May 5 09:57:59 Main_DC_Sofia fpc0 expr_dfw_bp_flt_num_ref_dec_ctr:386 bp_flt_num_ref_root null

    ==========================================

    Here is config sniped of QFX10002:

    ========================================

    set version 18.4R2-S3
    set system services ssh
    set system services telnet
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system extensions providers juniper license-type juniper deployment-scope commercial
    set system extensions providers chef license-type juniper deployment-scope commercial
    set chassis fpc 0 pic 0 port 49 speed 100g
    set chassis fpc 0 pic 0 port 59 speed 100g
    set interfaces et-0/0/0 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/48 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/49 unit 0 family ethernet-switching interface-mode trunk
    set interfaces et-0/0/49 unit 0 family ethernet-switching vlan members 100
    set interfaces et-0/0/49 unit 0 family ethernet-switching vlan members 111
    set interfaces et-0/0/49 unit 0 family ethernet-switching vlan members 999
    set interfaces et-0/0/49 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/50 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/58 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/59 unit 0 family ethernet-switching interface-mode trunk
    set interfaces et-0/0/59 unit 0 family ethernet-switching vlan members 100
    set interfaces et-0/0/59 unit 0 family ethernet-switching vlan members 111
    set interfaces et-0/0/59 unit 0 family ethernet-switching vlan members 999
    set interfaces et-0/0/59 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/60 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/71 unit 0 family ethernet-switching storm-control default
    set interfaces em0 unit 0 family inet dhcp
    set forwarding-options storm-control-profiles default all
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set protocols rstp disable
    set protocols rstp interface all
    set protocols mstp disable
    set protocols protection-group restore-interval 1
    set protocols protection-group guard-interval 10
    set protocols protection-group ethernet-ring GGG ring-protection-link-owner
    set protocols protection-group ethernet-ring GGG east-interface control-channel vlan 100
    set protocols protection-group ethernet-ring GGG east-interface control-channel et-0/0/49.0
    set protocols protection-group ethernet-ring GGG east-interface ring-protection-link-end
    set protocols protection-group ethernet-ring GGG west-interface control-channel vlan 100
    set protocols protection-group ethernet-ring GGG west-interface control-channel et-0/0/59.0
    set protocols protection-group ethernet-ring GGG control-vlan 100
    set protocols protection-group ethernet-ring GGG data-channel vlan 111
    set protocols protection-group ethernet-ring GGG data-channel vlan 999
    set vlans V100_ERP_Control vlan-id 100
    set vlans V111_GGG_ENV vlan-id 111
    set vlans V999_test_QP vlan-id 999

    =========================================

    Here is config sniped of one QFX5200:

    ==========================================

    set version 18.3R2-S2.1
    set system services ssh
    set system services telnet
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces et-0/0/47 unit 0 family ethernet-switching vlan members default
    set interfaces et-0/0/47 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/47 unit 0 family ethernet-switching vlan members default
    set interfaces ge-0/0/47 unit 0 family ethernet-switching storm-control default
    set interfaces xe-0/0/47 unit 0 family ethernet-switching vlan members default
    set interfaces xe-0/0/47 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/48 unit 0 family ethernet-switching interface-mode trunk
    set interfaces et-0/0/48 unit 0 family ethernet-switching vlan members 100
    set interfaces et-0/0/48 unit 0 family ethernet-switching vlan members 111
    set interfaces et-0/0/48 unit 0 family ethernet-switching vlan members 999
    set interfaces et-0/0/48 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/49 unit 0 family ethernet-switching interface-mode trunk
    set interfaces et-0/0/49 unit 0 family ethernet-switching vlan members 100
    set interfaces et-0/0/49 unit 0 family ethernet-switching vlan members 111
    set interfaces et-0/0/49 unit 0 family ethernet-switching vlan members 999
    set interfaces et-0/0/49 unit 0 family ethernet-switching storm-control default
    set interfaces et-0/0/50 unit 0 family ethernet-switching vlan members default
    set interfaces et-0/0/50 unit 0 family ethernet-switching storm-control default
    set interfaces vme unit 0 family inet dhcp
    set forwarding-options storm-control-profiles default all
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set protocols rstp disable
    set protocols rstp interface et-0/0/47
    set protocols rstp interface ge-0/0/47
    set protocols rstp interface xe-0/0/47
    set protocols rstp interface et-0/0/48 disable
    set protocols rstp interface et-0/0/49 disable
    set protocols rstp interface et-0/0/50
    set protocols mstp disable
    set protocols mstp interface et-0/0/48 disable
    set protocols mstp interface et-0/0/49 disable
    set protocols protection-group ethernet-ring GGG east-interface control-channel vlan 100
    set protocols protection-group ethernet-ring GGG east-interface control-channel et-0/0/48.0
    set protocols protection-group ethernet-ring GGG west-interface control-channel vlan 100
    set protocols protection-group ethernet-ring GGG west-interface control-channel et-0/0/49.0
    set protocols protection-group ethernet-ring GGG control-vlan 100
    set protocols protection-group ethernet-ring GGG data-channel vlan 111
    set protocols protection-group ethernet-ring GGG data-channel vlan 999
    set vlans V100_ERP_Control vlan-id 100
    set vlans V111_GGG_ENV vlan-id 111
    set vlans V999_test_QP vlan-id 999
    set vlans default vlan-id 1

    ============================================

    Other QFX5200 is configured the same way.

    Any help will be appreciated.
    Thank you,
    Ivo