Switching

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Captive Portal on EX2200-C and/or EX4200

    Posted 11-17-2015 10:08

    Hi there, Im looking for sone guidance on getting Captive Portal to actually function correctly

     

    Here is the config I have on both switches.

     

    On the EX4200 I am presented with a login page however I cannot login as the aptive user I can only login as a system user and then that brings me to the JWeb gui.

     

    On the EX2200-C I get no auth page at all.

     

    Both switches are configured the same and hey both have the full GUI instlled and running 15.1R2.9 code

     

     

    vlan {
            unit 70 {
                family inet {
                    primary;
                    address 192.168.70.254/24;
    }
    
    services {
              captive-portal {
                          authentication-profile-name CaptivePortal
                                       }
                          interface {
                                ge-0/0/10.0 {
                                     supplicant multiple;
                                         }
                                     }
                        secure-authentication https;
                               }
    }
    
    
    
    access {
    radius-server {
        192.168.69.21 secret "xxxxxxxxx"; ## SECRET-DATA
    }
    profile CaptivePortal {
        authentication-order radius;
        radius {
            authentication-server 192.168.69.21;
        }
    }

     

     

    Any help would be greatly appreciated.



  • 2.  RE: Captive Portal on EX2200-C and/or EX4200
    Best Answer

    Posted 11-19-2015 21:55

    I have my two issues solved, on the EX4200 I needed to use source-address option under each radius server entry.

    On the EX2200C I was missing the primary command on the vlan.xx interface. all is good and happy now, 802.1x then failback to web portal to gain access usign simple radius backend.



  • 3.  RE: Captive Portal on EX2200-C and/or EX4200

    Posted 11-09-2021 12:54
    Erdem,

    how did you configure  the web authentication server?

    ------------------------------
    CURTIS BRADLEY
    ------------------------------