Intrusion Prevention

 View Only


This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.

  • 1.  Upgrade from IDP v4.1r3 to v5 fails

    Posted 10-19-2009 07:08

    Hi, has anyone been successful in upgrading an IDP from v4 to v5?


    I have several IDP800 which I factory reset (using USB key) to v4.1r2a

    I then upgrade to v4.1r3  (because the upgrade path to v5 is only via r3 and not r2)

    I upgrade to v5


    It fails every time with some of the services not starting and unable to start, CLI commands not working and no connection possible over IP. I've repeated the same process with multiple units all from clean factory reset and with only default config. Upgrade is via command line.


    Any clues what I might be doing wrong? Has anyone been successful in an upgrade to v5?




  • 2.  RE: Upgrade from IDP v4.1r3 to v5 fails

    Posted 10-27-2009 12:37



    I have similar problem with my IDP 600C. When I try to upgrade from 4.1r3 to 5.0 I couldn't do it from CD or even via SH file.

    I report this to JTAC and they couldn't solved my problem so we request RMA for device.


    JTAC also gave me 2 special version of SW 5.0 release, but this also haven't help.


    Try first downgrade your IDP box to SW version 4.1r2 via CD. Then upload SW 4.1r3 SH file and upgrade your IDP device. After this upload also SW 5.0 SH file and upgrade again. This procedure work for my other IDP 200 device.




  • 3.  RE: Upgrade from IDP v4.1r3 to v5 fails

    Posted 10-28-2009 00:56

    Hi, thank you for the reply. I hope you do not have the exact same issue as me as I have tested on many different IDP with the same result. Therefore it is not a hardware issue.


    Good luck with the new unit.


  • 4.  RE: Upgrade from IDP v4.1r3 to v5 fails
    Best Answer

    Posted 10-29-2009 10:02

    I have had a little success so I'm writing this to aid future users.


    There is a technical buggette with the upgrade process to 5.0. If there is zero config the upgrade fails as described above. If you go through the initial config then the upgrade works. For some reason the last part of the upgrade does not work if you perform it from a factory install.


    Therefore the working path to a v5 IDP from a factory install is:


    1) Factory reset using USB/CD

    2) login to IDP and run through initial script giving basic IP info

    3) upgrade to 4.1r3

    4) delete v4 install file and reboot

    5) upgrade to 5.0


    If you fail to perform step 2 in the process then it will fail.