Hi,
I have a Cisco switch which has the following configuration to redistribute route to OSPF. Recently, I need to migrate the switch to Juniper Ex4300 with advance license. It seems very different when converting the configuration between Cisco and Juniper. I would like to ask for help to what configuration on Juniper switch to achieve the same result on Cisco switch? Many thanks... I have done some works on Juniper switch but I don't know the configuration is correct or not.
router ospf 99
log-adjacency-changes
redistribute static metric 1000 metric-type 1 subnets route-map FOR_TEST_1
redistribute bgp 99
passive-interface Vlan202
network 10.99.0.0 0.0.255.255 area 99
!
ip route 10.99.0.0 255.255.0.0 Null0
access-list 20 permit 10.99.0.0 0.0.255.255
route-map FOR_TEST_1 permit 10
match ip address 20
On Juniper switch
set policy-options policy-statement FOR_TEST_1 term 20 from protocol static
set policy-options policy-statement FOR_TEST_1 term 20 from route-filter 10.99.0.0/16 exact
set policy-options policy-statement FOR_TEST_! term 20 then accept
set firewall family inet filter permit20 term 20 from source-address 10.99.0.0/16
set firewall family inet filter permit20 term 20 then accept
set routing-options static route 10.99.0.0/16 discard
set protocols ospf area 0.0.0.99 interface irb.50 passive
set protocols ospf area 0.0.0.99 interface irb.50 metric 1000
set protocols ospf area 0.0.0.99 interface irb.99
set protocols ospf area 0.0.0.99 interface lo0.0
set protocols ospf export FOR_TEST_1
------------------------------
KENNETH TO
------------------------------