Original Message:
Sent: 06-17-2024 14:03
From: Lukas
Subject: Outgoing routing over IRB/LT interface problem
Hi Farid and thank you for reply...
It's maybe a bit weird setup, but in the reality MX sits between two infrastructure (et-0/0/0, xe-0/1/4), not just between few hosts and i have to have transparent L2 in the same vlan in which there is a bgp peers. So I'm trying to solve in this way.
------------------------------
Lukas
Original Message:
Sent: 06-16-2024 02:50
From: FARID AKHUNDOV
Subject: Outgoing routing over IRB/LT interface problem
Hi,
Well, first of all, why would you even need lt for this?
Why wouldn't you assign to each host port relevant VLAN and then do inter-vlan routing on MX, to which these VLANs are passed inside trunk port? The implementation does not seem to be reasonable.
------------------------------
FARID AKHUNDOV
Original Message:
Sent: 06-13-2024 12:47
From: Lukas
Subject: Outgoing routing over IRB/LT interface problem
Hello, please could someone help me understand why following scenarios has a problem with routing thru lt-0/0/0?
In case of A, packets(icmp) from HOST1 to HOST2 arrive to MX (verified by mirroring on sw1) and it's all, routing doesn't working.
In case of B, packets(icmp) from HOST1 to HOST2 arrive to MX and is forwarded to HOST2. Response packets to HOST1 arrive to MX and it's all, routing doesn't working.
In case of B, pure l2 from other hosts connected to SW1/2 in same vlans(1234/1235) thru MX working fine.
In case of both interfaces/units are in the same LS, all working like expected.
Many thanks for your time, Lukas
Topology-A:
HOST1(1.2.3.1/24)---v1234---\
SW1----(et-0/0/0, trunk)MX204
HOST2(1.2.4.1/24)---v1235---/
Configuration-A:
#show interfaces
lt-0/0/0 {
unit 1 {
peer-unit 0;
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
et-0/0/0 {
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
#show bridge-domains
test1 {
vlan-id 1234;
}
test2 {
vlan-id 1235;
}
#show logical-systems test
interfaces {
lt-0/0/0 {
unit 0 {
peer-unit 1;
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
irb {
unit 1234 {
family inet {
address 1.2.3.5/24;
}
}
unit 1235 {
family inet {
address 1.2.4.5/24;
}
}
}
}
bridge-domains {
test1 {
vlan-id 1234;
routing-interface irb.1234;
}
test2 {
vlan-id 1235;
routing-interface irb.1235;
}
}
Topology-B:
HOST1(1.2.3.1/24)---v1234---SW1----(et-0/0/0, trunk)MX204(xe-0/1/4, trunk)----SW2---v1235---(1.2.4.1/24)HOST2
Configuration-B:
#show interfaces
lt-0/0/0 {
unit 1 {
peer-unit 0;
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
et-0/0/0 {
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
#show bridge-domains
test1 {
vlan-id 1234;
}
test2 {
vlan-id 1235;
}
#show logical-systems test
interfaces {
lt-0/0/0 {
unit 0 {
peer-unit 1;
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
xe-0/1/4 {
unit 0 {
family bridge {
interface-mode trunk;
vlan-id-list 1234-1235;
}
}
}
irb {
unit 1234 {
family inet {
address 1.2.3.5/24;
}
}
unit 1235 {
family inet {
address 1.2.4.5/24;
}
}
}
}
bridge-domains {
test1 {
vlan-id 1234;
routing-interface irb.1234;
}
test2 {
vlan-id 1235;
routing-interface irb.1235;
}
}
------------------------------
Lukas
------------------------------