Routing

 View Only
last person joined: 4 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  mvpn via rsvp only

    Posted 07-31-2023 21:25

    I have a following topology to test this

    mreceiver <------- PE1  <-------- RR <-------- PE2 <--------- msender

    On PE1, PE2 and RR, there is no ldp at all.  When PE1 directly peers PE2 via bgp, Multicast works, but it PE1 and PE2 peer with RR, it does not work. The following is from RR

    set version 14.1R1.10
    set system host-name RR
    set system services ssh root-login allow
    set chassis fpc 0 pic 0 tunnel-services
    set interfaces ge-0/0/0 vlan-tagging
    set interfaces ge-0/0/0 unit 10 vlan-id 10
    set interfaces ge-0/0/0 unit 10 family inet address 10.50.0.212/31
    set interfaces ge-0/0/0 unit 10 family mpls
    set interfaces ge-0/0/2 vlan-tagging
    set interfaces ge-0/0/2 unit 10 vlan-id 10
    set interfaces ge-0/0/2 unit 10 family inet address 10.50.0.68/31
    set interfaces ge-0/0/2 unit 10 family mpls
    set interfaces ge-0/0/9 unit 0 family inet address 10.146.40.145/24
    set interfaces lo0 unit 0 family inet address 10.50.0.2/32
    set routing-options router-id 10.50.0.2
    set routing-options autonomous-system 64850
    set protocols rsvp interface all
    set protocols mpls no-cspf
    set protocols mpls interface ge-0/0/0.10
    set protocols mpls interface ge-0/0/2.10
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 10.50.0.2
    set protocols bgp group iBGP family inet unicast
    set protocols bgp group iBGP family inet-vpn unicast
    set protocols bgp group iBGP family inet-mvpn signaling
    set protocols bgp group iBGP cluster 2.2.2.2
    set protocols bgp group iBGP neighbor 10.50.0.3
    set protocols bgp group iBGP neighbor 10.50.0.5
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/2.10 interface-type p2p
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.10 interface-type p2p

    When I tested ldp only, I have to "set protocols ldp p2mp" on RR. Do I need to configure p2mp on RR for rsvp, if yes, how should I do it?  I have to configure lsp path for both PE1 and PE2  to RR and vice verse ?

    thanks !!



  • 2.  RE: mvpn via rsvp only

    Posted 08-01-2023 23:14

    very happy to have it figured out.
    The issue was the routes hidden because of no inet.3 table,  I added the following 2 lines after I came across this link

    set routing-options resolution rib inet.3 resolution-ribs inet.0

    set routing-options resolution rib bgp.l3vpn.0 resolution-ribs inet.0