I have a following topology to test this
mreceiver <------- PE1 <-------- RR <-------- PE2 <--------- msender
I used to use rsvp, but I like to test ldp only. I have the following configuration
set version 14.1R1.10
set system host-name PE1
set system services ssh root-login allow
set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 unit 100 vlan-id 100
set interfaces ge-0/0/0 unit 100 family inet address 10.146.196.161/27
set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/1 unit 1000 vlan-id 1000
set interfaces ge-0/0/1 unit 1000 family inet address 10.146.32.100/24
set interfaces ge-0/0/2 vlan-tagging
set interfaces ge-0/0/2 unit 10 vlan-id 10
set interfaces ge-0/0/2 unit 10 family inet address 10.50.0.69/31
set interfaces ge-0/0/2 unit 10 family mpls
set interfaces ge-0/0/9 unit 0 family inet address 10.146.40.141/24
set interfaces vt-0/0/10 unit 0 family inet
set interfaces lo0 unit 0 family inet address 10.50.0.3/32
set interfaces lo0 unit 3 family inet address 10.50.255.4/32
set routing-options router-id 10.50.0.3
set routing-options autonomous-system 64850
set protocols mpls icmp-tunneling
set protocols mpls label-switched-path mcar-hmb->mcar-umsa to 10.50.0.5
set protocols mpls interface ge-0/0/2.10
set protocols bgp group iBGP type internal
set protocols bgp group iBGP local-address 10.50.0.3
set protocols bgp group iBGP family inet unicast
set protocols bgp group iBGP family inet-vpn unicast
set protocols bgp group iBGP family inet-mvpn signaling
set protocols bgp group iBGP neighbor 10.50.0.2
set protocols ospf area 0.0.0.0 interface ge-0/0/2.10 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface ge-0/0/2.10
set protocols ldp interface lo0.0
set protocols ldp p2mp
set routing-instances spclab instance-type vrf
set routing-instances spclab interface ge-0/0/0.100
set routing-instances spclab interface ge-0/0/1.1000
set routing-instances spclab interface vt-0/0/10.0 multicast
set routing-instances spclab interface lo0.3
set routing-instances spclab route-distinguisher 64850:3
set routing-instances spclab provider-tunnel ldp-p2mp
set routing-instances spclab vrf-target target:64850:64850
set routing-instances spclab vrf-table-label
set routing-instances spclab protocols pim rp local address 10.50.255.4
set routing-instances spclab protocols pim interface all
set routing-instances spclab protocols mvpn
set version 14.1R1.10
set system host-name PE2
set system services ssh root-login allow
set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
set interfaces ge-0/0/0 vlan-tagging
set interfaces ge-0/0/0 unit 10 vlan-id 10
set interfaces ge-0/0/0 unit 10 family inet address 10.50.0.213/31
set interfaces ge-0/0/0 unit 10 family mpls
set interfaces ge-0/0/1 vlan-tagging
set interfaces ge-0/0/1 unit 1000 vlan-id 1000
set interfaces ge-0/0/1 unit 1000 family inet address 10.144.32.100/24
set interfaces ge-0/0/9 unit 0 family inet address 10.146.40.146/24
set interfaces vt-0/0/10 unit 0 family inet
set interfaces lo0 unit 0 family inet address 10.50.0.5/32
set routing-options router-id 10.50.0.5
set routing-options autonomous-system 64850
set protocols mpls interface ge-0/0/0.10
set protocols bgp group iBGP type internal
set protocols bgp group iBGP local-address 10.50.0.5
set protocols bgp group iBGP family inet unicast
set protocols bgp group iBGP family inet-vpn unicast
set protocols bgp group iBGP family inet-mvpn signaling
set protocols bgp group iBGP neighbor 10.50.0.2
set protocols ospf area 0.0.0.0 interface ge-0/0/0.10 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface ge-0/0/0.10
set protocols ldp interface lo0.0
set protocols ldp p2mp
set routing-instances spclab instance-type vrf
set routing-instances spclab interface ge-0/0/1.1000
set routing-instances spclab interface vt-0/0/10.0 multicast
set routing-instances spclab route-distinguisher 10.50.0.5:5
set routing-instances spclab provider-tunnel ldp-p2mp
set routing-instances spclab vrf-target target:64850:64850
set routing-instances spclab vrf-table-label
set routing-instances spclab protocols pim rp static address 10.50.255.4
set routing-instances spclab protocols pim interface all
set routing-instances spclab protocols mvpn
On PE2
root@PE2# run show multicast route instance spclab
Instance: spclab Family: INET
Group: 239.255.0.0
Source: 10.144.32.12/32
Upstream interface: ge-0/0/1.1000
Instance: spclab Family: INET6
No downstream interface list
Can I use ldp only for mvpn ?
If I use rsvp and configure provider-tunnel rsvp-te, it works.
thanks for help !!