Routing

 View Only
last person joined: yesterday 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  How eSetting up ACX's interface for QinQ?

    Posted 25 days ago

    Hello.

    I have a lab test scenario  that the original purpose is about to bridging the q-in-q at double vlans through VXLAN. I have two topologies that will have to show you.

    ## --- First topology. ---
    
    Basically we have 2 QFX5120s as leaf switches, 1 QFX5200 as spine, and 1 MX240 that will have 2 virtual routers for serving the endpoints.
    
    MX240[VR1] ge-2/1/4.200 <---> ge-0/0/0.200 QFX5120  et-0/0/48.0<---> et-0/0/5.0 QFX5200 et-0/0/2.0 <---> et-0/0/48.0 QFX5120 ge-0/0/0.200 <---> ge-2/1/3.200  MX240[VR2]
    
    Let's jump for VXLAN's complications, there is no problem.  Go to endpoints and leaf switches. This will be my configuration for MX240 and QFX5120 for taking bridge for dual tag VLANs.
    
    ## MX240 configurations.
    {master:member0-re0}
    xxx@MX240_LAB_CE2> show configuration interfaces ge-2/1/3  
    description CE2;
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation flexible-ethernet-services;
    unit 209 {
        vlan-tags outer 200 inner 20;
        family inet {
            address 10.0.1.0/31;
        }
    }
    
    {master:member0-re0}
    xxx@MX240_LAB_CE2> show configuration interfaces ge-2/1/4    
    description CE1;
    disable;
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation flexible-ethernet-services;
    unit 200 {
        vlan-tags outer 200 inner 20;
        family inet {
            address 10.0.1.1/31;
        }
    }
    
    {master:member0-re0}
    xxx@MX240_LAB_CE2> show configuration routing-instances 
    CE2 {
        instance-type virtual-router;
        interface ge-2/1/3.200;
    }
    CE3 {
        instance-type virtual-router;
        interface ge-2/1/4.200;
    }
    
    ## QFX5120 configurations.
    
    {master:0}
    xxx@QFX5120-48Y-LEAF-A1> show configuration interfaces ge-0/0/0 
    description to.ce2;
    flexible-vlan-tagging;
    mtu 9216;
    unit 200 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members vn200;
            }
        }
    }
    
    {master:0}
    xxx@QFX5120-48Y-LEAF-A1> show configuration routing-instances evpn-1 
    instance-type mac-vrf;
    ....
    vlans {
        vn200 {
            description VLAN200;
            vlan-id 200;
            vxlan {
                vni 10012;
                encapsulate-inner-vlan;
            }
        }
    }
    
    xxx@QFX5120-48Y-LEAF-A1> show configuration protocols l2-learning 
    decapsulate-accept-inner-vlan;
    telemetry {
        enable-remote-entries;
    }
    
    And another QFX5120 with the same pattern configuration.

    It did success carry my ping test to another virtual router of my MX240. With the test would be S-VLAN in 200 and C-VLAN 20. The leaf switches is able to carry on S-VLAN 200. Then my next topology.

    ## --- Second topology ---
    
    Now we have 1 QFX5120 as leaf switch, 1 ACX7100 as leaf switch, 1 QFX5200 as spine, 1 MX240 with 1 virtual router, 1 QFX5120 as serving endpoint.
    
    QFX5120  et-0/0/5.200<---> et-0/0/4.200  ACX7100  et-0/0/48.0 <---> et-0/0/0.0 QFX5200 et-0/0/2.0 <---> et-0/0/48.0 QFX5120 ge-0/0/0.200 <---> ge-2/1/3.200  MX240[VR2]
    
    Basically we just copy the same configuration. The ACX7100 has a problem when try to bridge dual tags from it's endpoint from QFX5120.
    
    ##QFX5120 configurations.
    {master:0}
    xxx@QFX5120-48Y-LEAF-B1> show configuration interfaces et-0/0/50    
    description CE1;
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation flexible-ethernet-services;
    unit 200 {
        vlan-tags outer 200 inner 20;
        family inet {
            address 10.0.1.1/31
        }
    }
    
    ## ACX7100 configurations.
    xxx@ACX7100-32C-BD-LEAF1> show configuration interfaces et-0/0/4                  
    description "to CE1 port et-0/0/48";
    flexible-vlan-tagging;
    speed 40g;
    mtu 9216;
    unit 200 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members vn200;
            }
        }
    }
    
    xxx@ACX7100-32C-BD-LEAF1> show configuration routing-instances evpn-1               
    instance-type mac-vrf;
    ....
    vlans {
        vn200 {
            description VLAN200;
            vlan-id 200;
            vxlan {
                vni 10012;
                encapsulate-inner-vlan;
                decapsulate-accept-inner-vlan;
            }
        }
    }
    
    ## QFX5120 configurations.
    {master:0}
    xxx@QFX5120-48Y-LEAF-A1> show configuration interfaces ge-0/0/0 
    description to.ce2;
    flexible-vlan-tagging;
    mtu 9216;
    unit 200 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members vn200;
            }
        }
    }
    
    {master:0}
    xxx@QFX5120-48Y-LEAF-A1> show configuration routing-instances evpn-1 
    instance-type mac-vrf;
    ....
    vlans {
        vn200 {
            description VLAN200;
            vlan-id 200;
            vxlan {
                vni 10012;
                encapsulate-inner-vlan;
            }
        }
    }
    
    xxx@QFX5120-48Y-LEAF-A1> show configuration protocols l2-learning 
    decapsulate-accept-inner-vlan;
    telemetry {
        enable-remote-entries;
    }
    
    ## MX240 configurations.
    {master:member0-re0}
    xxx@MX240_LAB_CE2> show configuration interfaces ge-2/1/3  
    description CE2;
    flexible-vlan-tagging;
    mtu 9216;
    encapsulation flexible-ethernet-services;
    unit 209 {
        vlan-tags outer 200 inner 20;
        family inet {
            address 10.0.1.0/31;
        }
    }

    Still receiving the MAC address from QFX5120 leaf switches, but ACX7100 doesn't catch the MAC address from QFX5120 endpoint at this time. So my basic question is, just how to make ACX7100 is accepting the dual VLAN tags for bridging them likewise of QinQ? We did take test for one vlan tag, and it did sucess. Is there any missing on the configuration on ACX7100? I did suspect of missing configuration at the interface,

    Need some clues. :) 



  • 2.  RE: How eSetting up ACX's interface for QinQ?

    Posted 25 days ago

    I also having the output on both ACX7100 and QFX5120.

    xxx@ACX7100-32C-BD-LEAF1> show interfaces et-0/0/4.200 extensive 
      Logical interface et-0/0/4.200 (Index 1039) (SNMP ifIndex 596) (Generation 627065226570)
        Flags: Up SNMP-Traps VLAN-Tag[ 0x0000.0 ]  Encapsulation: Ethernet-Bridge DF
      Traffic statistics:
       Input  bytes  :                    0
       Output bytes  :                16056
       Input  packets:                    0
       Output packets:                  217
       Local statistics:
        Input  bytes  :                    0
        Output bytes  :                 2680
        Input  packets:                    0
        Output packets:                    8
       Transit statistics:
        Input  bytes  :                    0                    0 bps
        Output bytes  :                13376                 3344 bps
        Input  packets:                    0                    0 pps
        Output packets:                  209                    2 pps
        Protocol ethernet-switching, MTU: 9216, Generation: 627065226571, Route table: 55, Mesh Group: __all_ces__, Next-hop: 9065
          Flags: Is-Primary, Trunk-Mode

    {master:0}
    xxx@QFX5120-48Y-LEAF-A1> show interfaces ge-0/0/0.200 extensive 
      Logical interface ge-0/0/0.200 (Index 820) (SNMP ifIndex 536) (HW Token 1) (Generation 269)
        Flags: Up SNMP-Traps 0x20024000 Encapsulation: Ethernet-Bridge
        Traffic statistics:
         Input  bytes  :                    0
         Output bytes  :                    0
         Input  packets:                    0
         Output packets:                    0
       Local statistics:
        Input  bytes  :                    0
        Output bytes  :                    0
        Input  packets:                    0
        Output packets:                    0
       Transit statistics:
        Input  bytes  :                    0                    0 bps
        Output bytes  :                    0                    0 bps
        Input  packets:                    0                    0 pps
        Output packets:                    0                    0 pps
        Protocol eth-switch, MTU: 9216, Generation: 270, Route table: 11, Mesh Group: __all_ces__, Next-hop: 1778, vpls-status: up
          Flags: Is-Primary, Trunk-Mode, 0x4000000

    I noticed that ACX7100 doesn't make the same output just like QFX5120. QFX5120 is quite simple which it is transparently accept everyting. But in ACX7100 has VLAN Tag 0x0000.0. It should has en effect on it. And on the next, Ethernet-Bridge DF. What is DF at this point?