Routing

 View Only
last person joined: yesterday 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.

EVPN T5 routes between vSRX and vEX - Bug?

  • 1.  EVPN T5 routes between vSRX and vEX - Bug?

    Posted 06-29-2024 21:20

    On newer 23.4 code, you can send Type 5 routes via evpn signaling.

    I can ping 192.168.50.1 from the vEX to the vSRX, but not 192.168.60.1 from the SRX to the vEX.

    However, traceroute does work from the vSRX to the vEX. See below for example and config. 

    Thoughts? 

    root@vEX# run ping 192.168.50.1 routing-instance CustA    
    PING 192.168.50.1 (192.168.50.1): 56 data bytes
    64 bytes from 192.168.50.1: icmp_seq=0 ttl=65 time=2.994 ms
    64 bytes from 192.168.50.1: icmp_seq=1 ttl=65 time=20.685 ms
    64 bytes from 192.168.50.1: icmp_seq=2 ttl=65 time=2.890 ms
    64 bytes from 192.168.50.1: icmp_seq=3 ttl=65 time=17.019 ms
    64 bytes from 192.168.50.1: icmp_seq=4 ttl=65 time=4.303 ms
    64 bytes from 192.168.50.1: icmp_seq=5 ttl=65 time=32.407 ms
    64 bytes from 192.168.50.1: icmp_seq=6 ttl=65 time=32.513 ms
    
    root@vSRX# run ping 192.168.60.1 routing-instance CustA          
    PING 192.168.60.1 (192.168.60.1): 56 data bytes
    ^C
    --- 192.168.60.1 ping statistics ---
    7 packets transmitted, 0 packets received, 100% packet loss
    
    [edit]
    root@vSRX# run traceroute 192.168.60.1 routing-instance CustA 
    traceroute to 192.168.60.1 (192.168.60.1), 30 hops max, 52 byte packets
    1  192.168.60.1 (192.168.60.1)  3.049 ms  2.158 ms  1.788 ms

    vEX
     
    }
    interfaces {
        ge-0/0/0 {
            unit 0 {
                family inet {
                    address 100.64.0.1/24;
                }
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    address 1.1.1.1/32;
                }
            }
            unit 1 {                        
                family inet {
                    address 192.168.60.1/24;
                }
            }
        }
    }
    routing-instances {
        CustA {
            instance-type vrf;
            protocols {
                evpn {
                    ip-prefix-routes {
                        advertise direct-nexthop;
                        encapsulation vxlan;
                        vni 100;
                    }
                }
            }
            interface lo0.1;
            route-distinguisher 1.1.1.1:10;
            vrf-target target:65000:10;
            vrf-table-label;
        }                                   
    }
    routing-options {
        router-id 1.1.1.1;
        autonomous-system 65000;
    }
    protocols {
        ##
        ##
        bgp {
            group Overlay {
                type internal;
                multihop;
                local-address 1.1.1.1;
                family evpn {
                    signaling;
                }
                neighbor 2.2.2.2;
            }
        }
        evpn {
            no-core-isolation;
            encapsulation vxlan;            
            default-gateway do-not-advertise;
            extended-vni-list all;
        }
        ospf {
            area 0.0.0.0 {
                interface all;
            }
        }
    }
    switch-options {
        vtep-source-interface lo0.0;
        route-distinguisher 1.1.1.1:1;
        vrf-target {
            target:65000:1;
            auto;
        }
    }
     
     
     
     
    ..................................................
     
    vSRX
     
    }
    security {
        policies {
            global {
                policy permit-all {
                    match {
                        source-address any;
                        destination-address any;
                        application any;
                    }
                    then {
                        permit;
                    }
                }
            }
        }                                   
        zones {
            security-zone Underlay {
                host-inbound-traffic {
                    system-services {
                        all;
                    }
                    protocols {
                        all;
                    }
                }
                interfaces {
                    ge-0/0/0.0;
                }
            }
            security-zone CustA {
                host-inbound-traffic {
                    system-services {
                        all;
                    }
                    protocols {
                        all;
                    }
                }                           
                interfaces {
                    lo0.1;
                }
            }
        }
    }
    interfaces {
        ge-0/0/0 {
            unit 0 {
                family inet {
                    address 100.64.0.2/24;
                }
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    address 2.2.2.2/32;
                }
            }
            unit 1 {
                family inet {
                    address 192.168.50.1/24;
                }
            }
        }
    }
    routing-instances {
        CustA {
            instance-type vrf;
            protocols {
                evpn {
                    ip-prefix-routes {
                        advertise direct-nexthop;
                        encapsulation vxlan;
                        vni 110;
                    }
                }
            }
            interface lo0.1;
            route-distinguisher 2.2.2.2:10;
            vrf-target target:65000:10;
            vrf-table-label;
        }
    }
    protocols {                             
        ospf {
            area 0.0.0.0 {
                interface all;
            }
        }
        bgp {
            group Overlay {
                type internal;
                multihop;
                local-address 2.2.2.2;
                family evpn {
                    signaling;
                }
                neighbor 1.1.1.1;
            }
        }
    }
    routing-options {
        router-id 2.2.2.2;
        autonomous-system 65000;
    }