Junos OS

Expand all | Collapse all

EX4300 upgrade

Jump to Best Answer
  • 1.  EX4300 upgrade

    Posted 01-13-2020 04:09

    Hi I did an upgrade on my EX 4300 Juniper from version 19.1R1 to version 19.4R1 and i noticed that the web interface doesn't work after searching around I found out that the httpd.conf file is missing (i used the find command, nothing) and the httpd service doesn't even start. Is there a way to regenerate this file? What can i do? If I revert the upgrade will that work? The switch is not configured at all I wanted to upgrade before configuration after the upgrade I set the management interface and web-management configurations when I noticed the problem.



  • 2.  RE: EX4300 upgrade

     
    Posted 01-13-2020 04:18

    Hi hajdusz,

     

    is there any specific reason that you need 19.4R1 on your EX switch? Please note that latest and greatest JUNOS release are the most unstable release as well. The currently recommended release for EX4300 is Junos 18.1R3-S8/18.4R2-S2 (updated on Dec 10th). Please see the following link for the recommended releases:

     

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB21476

     

    If you don't need any specific feature, and if stability is important for you, I'd suggest to downgrade to 18.1R3-S8 or 18.4R3 and then check again if your issue is solved or not.



  • 3.  RE: EX4300 upgrade

    Posted 01-13-2020 04:25

    Thank you for the replay I did not know that the newest is not the most stable. I will try this .



  • 4.  RE: EX4300 upgrade

     
    Posted 01-13-2020 04:29

    You're welcome, please mark my post as "Accepted Solution" if the downgrade works for you.



  • 5.  RE: EX4300 upgrade
    Best Answer

    Posted 01-23-2020 00:21

    Ok sorry for the long wait this was a weird one but I managed to fix it.

    First I installd a stabel 18 firmware the httpd.conf was still mising so I askd a friend and copied a default config to the switch. After the restart i had to delete system phone-home server https://redirect.juniper.net and system phone-home rfc-compliant another restart then the switch used my default configuration modified the web-management part in cli and it works now.