Switching

Expand all | Collapse all

Etherchannel configruation

Jump to Best Answer
  • 1.  Etherchannel configruation

    Posted 06-13-2015 21:47

    The port link aggregation is not up between Cisco switch and Juniper switch. Below is the configuration. Anything not right? Please advise. Many thanks.

     

    Juniper:

      ge-0/0/46 {
            enable;
            ether-options {
                802.3ad ae0;
            }
        }
        ge-0/0/47 {
            enable;
            ether-options {
                802.3ad ae0;
            }
        }

       ae0 {
            mtu 1500;
            aggregated-ether-options {
                lacp {
                    active;
                    periodic fast;
                }
            }
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members all;
                    }
                }
            }
        }

     

    Cisco:

    interface FastEthernet0/21
     switchport trunk encapsulation dot1q
     switchport mode trunk

    channel-protocol lacp
     channel-group 1 mode active

    interface FastEthernet0/22
     switchport trunk encapsulation dot1q
     switchport mode trunk

    channel-protocol lacp
     channel-group 1 mode active

     

    interface Port-channel1
     switchport trunk encapsulation dot1q
     switchport mode trunk

     

     



  • 2.  RE: Etherchannel configruation
    Best Answer

    Posted 06-14-2015 02:45

    "interface FastEthernet0/21"

    looks like the CISCO is 10x100 (fe) and juniper is 10x100x1000 (ge) so you would need to set the juniper ports to 100 mb

    # set ge-0/0/46 and 47 ether-options speed 100mb

     

    I don't know if LAG can be configured for such low speeds, but that may be the problem.

    Verify that the MTU on CISCO is 1500 also