Expand all | Collapse all

Error while upgrading.

  • 1.  Error while upgrading.

    Posted 11-03-2017 14:28

    Hello Community. 


    I hope everyone is well. My office recently received an EX 9208 running 'JUNOS 14.1X53-D42.3' from factory. After carefully looking for a more updated version we proceed to upgrade the box to JUNOS 16.1R5.7' which actually is the one recommended by Juniper. 


    We did the upgrade through the CLI and we already had some Mgmt config in the Switch including a couple of VLANs. 


    Long story short. The Upgrade failed with the following command: 


    config/juniper.conf:220:  (5) syntax error at 'vlans'
    'vlans {'
    syntax error
    /config/juniper.conf:581:  (1) error recovery ignores input until this point at '}'
    error recovery ignores input until this point
    Validation failed
    ERROR: Current configuration not compatible with /var/tmp/junos-install-ex92xx-x86-64-16.1R5.7.tgz


    I cleared the VLANs from the config and then tried it again and it worked fine. 


    Does any one knows what could've caused this issue? Did something changed with this version as I am unable to find any known caveat within the official documentation reporting this behavior. 





  • 2.  RE: Error while upgrading.

    Posted 11-03-2017 23:36

    By default, during any JUNOS upgradation, new JUNOS version validiate consistency of the current active configuration with its feature library.


    Hence, you may use command request system software add /...... / no-validate 

    to avoid such errors.


    Juniper KB for your ref as well.



    The no-validate  turns off validation of current configuration against new Junos.

    Validation, sometimes throw some lines and stops installation, sometimes it won't show anything, but it doesn't mean that current config is fully compatible with new Junos.

    As an example, we had some newer version of Junos on EX. There was a VSTP+RSTP configuration. But we had to downgrade because of some issue. Older version did not support VSTP+RSTP config, only VSTP or RSTP. We did downgrade and after restart, switch didn't initialized and didn't commited this configuration and only shows that VSTP+RSTP config is incompatible, so part of our network was down.

    This was just an example when validation could warn you and disble upgrade. Validate possibly works only when upgrading.



  • 3.  RE: Error while upgrading.

    Posted 01-31-2018 20:31

    Fo SRX1400 ISSU cluster upgrade I am getting below error:

    Any suggestion to resolve the issue?


    root@SDBRONRS04W> ...unos-srx1k3k-12.3X48-D50.6-domestic.tgz
    Checking compatibility with configuration
    cp: /etc/iri_ipsec_key.db: No such file or directory
    Using /var/tmp/junos-srx1k3k-12.3X48-D50.6-domestic.tgz
    chroot: /bin/sh: No such file or directory
    ERROR: validate-config: junos/+REQUIRE fails
    WARNING: Current configuration not compatible with /var/tmp/junos-srx1k3k-12.3X48-D50.6-domestic.tgz


    I am upgrading the code from 12.1X46-D40.2 to  12.3X48

  • 4.  RE: Error while upgrading.

    Posted 06-20-2018 12:08

    I'm getting the same error except I'm upgrading from 12.3X48-D35 to D65 and using the ISSU feature for the cluster upgrade.  Did you find a solution to this?

    Not using ISSU and using the "no-validate" is not a good solution when dealing with production networks.  If the config is not compatible it would be nice to know what it doesn't like.

    In my case it was in regards to a service object that included a uuid of 000 000 00 000 or something like that, I didn't save the output.  Either way I updated my config to remove that object and use the junos-ms-rpc object, removed the invalid object from the firewall completely and commited the change.  Yet the upgrade still failed calling out the same error.  I rebooted and have not tried again as I need to set another change window.

  • 5.  RE: Error while upgrading.

    Posted 06-20-2018 12:28

    I know everyone wants ISSU for every product and situation, but since you already have a redundant cluster, is ISSU manditory?  Yes it should work, I believe (TAC would be best resource), but is it 100% neccessary?


    My 2 cents worth.