SRX

Expand all | Collapse all

SRX220H2 upgrading fails

Jump to Best Answer
  • 1.  SRX220H2 upgrading fails

    Posted 04-04-2016 01:44

    Hi Experts,

     

    I was trying to upgrade the SRX220H2 but getting the follwing error:

    root> request system software add /tmp/usb/junos-srxsme-12.3X48-D25.3-domestic.tgz no-validate no-copy
    WARNING: Package 12.3X48-D25.3 is not compatible with this hardware.
    WARNING: Please install an SRX image supported for 2G

     

    root> show version
    Model: srx220h2
    JUNOS Software Release [12.1X44-D35.5]

     

    I downloaded the software for SRX220 as I didn't find SRX220H2 in the download section.

     

    Thanks,

     

     



  • 2.  RE: SRX220H2 upgrading fails
    Best Answer

     
    Posted 04-04-2016 01:48

    Hello ,

     

    This is a known issue .

     

    Please upgrade your device to 12.1X46-D25, and then upgrade the 12.3X48 image .

     

    PR 1060920 [Confidential, Duplicate] - Unable to install 12.3X48 beta on SRX 220H2



  • 3.  RE: SRX220H2 upgrading fails

     
    Posted 04-04-2016 02:09

    Hello ,

     

    More details :

     

    On SRX100, SRX110, SRX210, and SRX220 devices with 2-GB RAM (for H2/HE2 models), software upgrade to Junos OS Release 12.3X48-D10 fails if the upgrade is done from a release earlier than Junos OS Release 12.1X44-D40, 12.1X45-D30, or 12.1X46-D25. The following error message is displayed:


    WARNING: Package 12.3X48-Dxx is not compatible with this hardware

     

     

    As a workaround, first upgrade Junos OS Release to 12.1X44-D40, 12.1X45-D30, 12.1X46-D25, 12.1X47-D10, or later and then continue to upgrade Junos OS Release to 12.3X48-D10.
    Refer https://kb.juniper.net/tsb16646.