SRX

Expand all | Collapse all

Best way of redundancy between SRX and EX?

Jump to Best Answer
  • 1.  Best way of redundancy between SRX and EX?

    Posted 03-05-2013 02:33

    So I have been configuring a setup with our new equipment (2 x SRX550 and 2 x EX4200) for a while and I just noticed when I was trying the redundant failover that there is an issue with the reth0 to ae0. When it fails it doesnt work as I wanted becuase it seems it is simply not supported from what I have found out. It seems the issue is with the reth not having all "up" links active, while ae does expect that.

     

    So I am asking how do you suggest I solve this? This must be pretty standard scenario? I tried finding on forum but no real good answers came up.

     

    I want to have a single link of a minimum of 2Gbps at all times. There is a totalt of 6 interfaces from each side availible for this.

     

    Any help is greatly appriciated. Example configuration of a solution even more so.

     

     

    Edit: I should mention they are in HA and VC.

     

     

    Here is the current configuration of SRX

    ge-0/0/6 {
        gigether-options {
            redundant-parent reth0;
        }
    }
    ge-0/0/7 {
        gigether-options {
            redundant-parent reth0;
        }
    }
    ge-0/0/8 {
        gigether-options {
            redundant-parent reth0;
        }
    }
    ge-9/0/6 {
        gigether-options {
            redundant-parent reth0;
        }
    }
    ge-9/0/7 {
        gigether-options {
            redundant-parent reth0;
        }
    }
    ge-9/0/8 {
        gigether-options {
            redundant-parent reth0;
        }
    }
    reth0 {
        vlan-tagging;
        redundant-ether-options {
            redundancy-group 1;
            minimum-links 1;
            lacp {
                active;
                periodic fast;
            }
        }
        unit 9 {
            vlan-id 9;
            family inet {
                address 192.168.9.1/24;
            }
        }
        unit 19 {
            vlan-id 19;
            family inet {
                address X.16.239.245/30;
            }
            family inet6 {
                address 2a02:X:0:ffff::1/64;
            }
        }
    }
    

     

    And here is current configuration of EX

    ge-0/1/0 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-0/1/1 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-0/1/2 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-1/1/0 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-1/1/1 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-1/1/2 {
        ether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        vlan-tagging;
        aggregated-ether-options {
            minimum-links 1;
            lacp {
                passive;
                periodic fast;
            }
        }
        unit 9 {
            vlan-id 9;
            family inet {
                address 192.168.9.2/24;
            }
        }
        unit 19 {
            vlan-id 19;
            family inet {
                address X.16.239.246/30;
            }
            family inet6 {
                address 2a02:X:0:ffff::2/64;
            }
        }
    }

     

     



  • 2.  RE: Best way of redundancy between SRX and EX?
    Best Answer

    Posted 03-05-2013 03:38

    Ok after I found http://kb.juniper.net/InfoCenter/index?page=content&id=KB22474&actp=RSS&smlogin=true I solved it.

    I'll post the solution if anyone else have the same issue.

     

    I now have this configuration on EX instead.

    ge-0/1/0 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-0/1/1 {
        ether-options {
            802.3ad ae0;
        }
    }
    ge-0/1/2 {
        ether-options {
            802.3ad ae1;
        }
    }
    ge-1/1/0 {
        ether-options {
            802.3ad ae1;
        }
    }
    ge-1/1/1 {
        ether-options {
            802.3ad ae1;
        }
    }
    ge-1/1/2 {
        ether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ EXTERNAL-LINK-TO-SRX INTERNAL-LINK-TO-SRX ];
                }
            }
        }
    }
    ae1 {
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ EXTERNAL-LINK-TO-SRX INTERNAL-LINK-TO-SRX ];
                }
            }
        }
    }

     

    Where the pysical link to SRX(1) is ae0 and the physical links to SRX(2) is ae1.

     

    Was able to pull cable by cable in both switches and it failed over as expected.