Hello All,
I am currently facing issues with OSPF over l2circuit.
the l2circuit is up . Both C.E can ping each other but neigbourship between CE is stuck at init state.
Topology
EX-4200-A-CE|------trunk------|EX-8200|-----trunk-----|MX-PE-A|-------l2ckt------|MX-PE-B|-----trunk------|EX-8200-CE-B|
Configuration
A-end configuration
{master}[edit]
arh@A.B262-MXPB-01# show protocols l2circuit
traceoptions {
file atif;
flag all;
}
neighbor x.x220.227 {
interface xe-1/3/0.1202 {
virtual-circuit-id 1202;
no-control-word;
mtu 1528;
}
}
arh@A.B262-MXPB-01# show interfaces xe-1/3/0
description Connected-to-A.B262-EXCR-02;
vlan-tagging;
encapsulation flexible-ethernet-services;
unit 100 {
description Connected-to-A.B262-EXCR-02;
vlan-id 100;
family inet {
address x.x242.38/30;
}
unit 1202 {
description " Alflah L2VPN";
encapsulation vlan-ccc;
vlan-id 1202;
family ccc;
}
EX-8200#confg
set vlans BAFL-L2 vlan-id 1202
EX-4200
show routing-instances TOspf
instance-type virtual-router;
interface vlan.1202;
interface vlan.1203;
protocols {
ospf {
traceoptions {
file test;
flag packets detail;
flag all;
}
area 0.0.0.0 {
interface vlan.1202;
interface vlan.1203;
}
}
}
BAFL-l2-1 {
vlan-id 1202;
l3-interface vlan.1202;
}
arh@VC-16# show interfaces vlan.1202
family inet {
address 10.10.10.1/24;
}
B -End config
MX-1-PE
======
set interfaces xe-2/3/0 unit 1202 description "I 16/07/13"
set interfaces xe-2/3/0 unit 1202 encapsulation vlan-ccc
set interfaces xe-2/3/0 unit 1202 vlan-id 1202
set interfaces xe-2/3/0 unit 1202 family ccc
set protocols l2circuit neighbor x.x.255.142 interface xe-2/3/0.1202 virtual-circuit-id 1202
set protocols l2circuit neighbor x.x.255.142 interface xe-2/3/0.1202 no-control-word
set protocols l2circuit neighbor x.x.255.142 interface xe-2/3/0.1202 mtu 1528
EX-1-CE
====
set routing-instances BAF-A.B-OSPF instance-type virtual-router
set routing-instances BAF-A.B-OSPF interface vlan.1202
set routing-instances BAF-A.B-OSPF interface vlan.1203
set routing-instances BAF-A.B-OSPF protocols ospf area 0.0.0.0 interface vlan.1202
set routing-instances BAF-A.B-OSPF protocols ospf area 0.0.0.0 interface vlan.1203
set interfaces vlan unit 1202 family inet address 10.10.10.2/24
set vlans BAFL-l2-1 vlan-id 1202
set vlans BAFL-l2-1 l3-interface vlan.1202
set interfaces vlan unit 1203 family inet address 10.10.11.2/24
set vlans BAFL-l2-2 vlan-id 1203
set vlans BAFL-l2-2 l3-interface vlan.1203
Show commands from A side
arh@A.B262-MXPB-01# run show l2circuit connections
Layer-2 Circuit Connections:
Legend for connection status (St)
EI -- encapsulation invalid NP -- interface h/w not present
MM -- mtu mismatch Dn -- down
EM -- encapsulation mismatch VC-Dn -- Virtual circuit Down
CM -- control-word mismatch Up -- operational
VM -- vlan id mismatch CF -- Call admission control failure
OL -- no outgoing label IB -- TDM incompatible bitrate
NC -- intf encaps not CCC/TCC TM -- TDM misconfiguration
BK -- Backup Connection ST -- Standby Connection
CB -- rcvd cell-bundle size bad SP -- Static Pseudowire
LD -- local site signaled down RS -- remote site standby
RD -- remote site signaled down XX -- unknown
Legend for interface status
Up -- operational
Dn -- down
Neighbor: x.x220.227
Interface Type St Time last up # Up trans
xe-1/3/0.1202(vc 1202) rmt Up Jul 30 16:49:55 2013 1
Remote PE: x.x220.227, Negotiated control-word: No
Incoming label: 540187, Outgoing label: 735402
Negotiated PW status TLV: No
Local interface: xe-1/3/0.1202, Status: Up, Encapsulation: VLAN
ping mpls l2circuit virtual-circuit 1202 neighbor x.x220.227 count 100 detail
Request for seq 1, to interface 95, labels <735402, 1, 268>, packet size 88
Reply for seq 1, return code: Egress-ok, time: 14.682 ms
Local transmit time: 2013-08-01 12:46:25 PKT 482.685 ms
Remote receive time: 2013-08-01 12:46:25 PKT 497.367 ms
Request for seq 2, to interface 95, labels <735402, 1, 268>, packet size 88
Reply for seq 2, return code: Egress-ok, time: 14.744 ms
Local transmit time: 2013-08-01 12:46:26 PKT 482.408 ms
Remote receive time: 2013-08-01 12:46:26 PKT 497.152 ms
Request for seq 3, to interface 95, labels <735402, 1, 268>, packet size 88
Reply for seq 3, return code: Egress-ok, time: 14.726 ms
Local transmit time: 2013-08-01 12:46:27 PKT 483.191 ms
Remote receive time: 2013-08-01 12:46:27 PKT 497.917 ms
Request for seq 4, to interface 95, labels <735402, 1, 268>, packet size 88
Reply for seq 4, return code: Egress-ok, time: 14.727 ms
Local transmit time: 2013-08-01 12:46:28 PKT 482.976 ms
Remote receive time: 2013-08-01 12:46:28 PKT 497.703 ms
Request for seq 5, to interface 95, labels <735402, 1, 268>, packet size 88
Reply for seq 5, return code: Egress-ok, time: 17.492 ms
Local transmit time: 2013-08-01 12:46:29 PKT 482.761 ms
Remote receive time: 2013-08-01 12:46:29 PKT 500.253 ms
Request for seq 6, to interface 95, labels <735402, 1, 268>, packet size 88
arh@VC-16# run ping 10.10.10.2 routing-instance TOspf
PING 10.10.10.2 (10.10.10.2): 56 data bytes
64 bytes from 10.10.10.2: icmp_seq=0 ttl=64 time=25.988 ms
64 bytes from 10.10.10.2: icmp_seq=1 ttl=64 time=37.410 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=64 time=34.317 ms
64 bytes from 10.10.10.2: icmp_seq=3 ttl=64 time=27.520 ms
{master:0}[edit]
arh@VC-16# run show ospf interface instance TOspf
Interface State Area DR ID BDR ID Nbrs
vlan.1202 DR 0.0.0.0 10.10.10.1 0.0.0.0 1
vlan.1203 DR 0.0.0.0 10.10.10.1 0.0.0.0 0
arh@VC-16# run show ospf neighbor instance TOspf
Address Interface State ID Pri Dead
10.10.10.2 vlan.1202 Init 10.10.10.2 128 32
#ospf#l2circuit