View Only
last person joined: 8 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  EX3300 Strange Behavior

    Posted 12-02-2021 05:35
    Edited by Michael Pappas 12-02-2021 09:34

    Hello friends,

    before I start with my actual problem, I should mention that I have 3 x EX3400 as a virtual chassis in production environment for almost 2 years (3?), so I'd say I have at least some experience in handling Juniper switches. We recently built a new headquarters, which included fiber connections to remote locations on the premises, so new switches were required. Since new devices would take up to half a year, my only solution was getting used ones, so I bought two EX3300 for an affordable price. 

    The 48T arrived yesterday and I immediately booted the device. So far so good, but at some point I read "corrupted configuration". After a long sigh and not knowing what the previous owners did, I decided to do a format install via usb (15.1R7.9), which worked out well. I already configured the VLANs and ports and want to deploy it tomorrow in the wiring closet in the maintenance area.

    2 things irk me massively though:

    1. I tried to install j-web via the recommended method in the documentation, but it did not take (which probably coincides with the second point I'm gonna make). Even though I don't use j-web even with our virtual chassis stack (I have a standing RS232 connection from my office to the VC), it would be nice to just have a look now and then

    2. When I "request system storage" on our VC, I get a very beautiful picture:

    When I do that on the EX3300, I get a very different picture:

    Am I wrong to assume that something did not work out right with either my format install or my j-web installation attempt? It looks very different. I also noticed that on the EX3300, in the login screen, it displays "Amnesiac (ttyu0)" instead of "FreeBSD/arm" (which shows on our EX3400 stack).

    Am I overreacting here and everything is fine or should I take additional steps to ensure the smooth operation of that new switch? 

    Thank you in advance!

    Benni Faller

  • 2.  RE: EX3300 Strange Behavior

    Posted 12-02-2021 09:36
    Hi Benni,

    1) Let us know the procedure you followed for j-web installation. You might have missed any step.

    Example: may not have enabled the j-web knob:

    set system services web-management http

    2) EX3300 and EX3400 are different platforms. Hence the difference in the output. It looks fine though.

    Amnesiac simply means switch booted with default configuration. The FreeBSD/arm is for EX2300/EX3400 series of switches.

  • 3.  RE: EX3300 Strange Behavior

    Posted 12-03-2021 05:38
    Hi avishm,

    thank you for the reply. The steps I took were pretty straightforward:

    - copy the jweb package (jweb-15.1R4.6-signed.tgz) from the corresponding support page on the Juniper website to the USB stick
    - mounting the USB stick to /var/tmp/usb
    - request system software add /var/tmp/usb/jweb-15.1R4.6-signed.tgz
    - set system services web-management http
    - of course I configured an interface and a corresponding IP (under interfaces   vlan unit 0 family inet address XXX.XXX.XXX.XXX/24 and then under vlans
     Management vlan-id 110 l3-interface vlan.0) -- I hope that was correct (I was a little confused since there was no irb interface syntax as on the EX3400, so I thought that was the problem, but I found out that on the 3300 that syntax is the correct one)

    Not sure what else to do here

    2) I was getting really nervous there for a second, haha. Thank you for clarifying that. I noticed it at the point whenI had to use "port-mode trunk" instead of "interface-mode trunk". It makes me happy though that there is no visible irregularity.

    It's morning for me now on this side of the planet, so I'm about to deploy that 3300 in the maintenance area now, but when I just did a  request system power-off in order to safely unplug it, I saw this in the console:

    I unplugged the PSU since the console did not react anymore and after the boot up was finished I did a request system reboot to make sure everything is working fine and it did. After that, I again did a request system power-off just to be sure and the system halted without any problems. "Fatal kernel mode data abort" does not sound good though. You think this is serious? 

    Thank you in advance!


  • 4.  RE: EX3300 Strange Behavior

    Posted 12-03-2021 15:55
    Hi Benni,

    Seems like system corruption on primary partition lead to switch falling into db promt. Since it halted without any problems second time, it must have booted from secondary partition. Since it's working fine now, you can take a snapshot to copy the working snapshot to the other partition using below command:

    request system snapshot slice alternate

    You can verify once done using below command:

    show system snapshot media internal

  • 5.  RE: EX3300 Strange Behavior

    Posted 03-25-2022 09:32
    Hi avishm,

    sorry for the long inactivity - I was in the hospital. I will get on that asap.

    Best regards