View Only
last person joined: 2 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  vqfx10k-pfe is not starting

    Posted 01-23-2017 23:06

    Hi all,

    I have an issue that I hope you can help me with.

    The vqfx-pfe software will not start, RE part works perfect.

    The only thing that happen is following


    @vqfx-10000:~/vqfx10k-vagrant/full-2qfx$ virsh console pfe-hostname

    Connected to domain pfe-hostname

    Escape character is ^]

      Booting `Juniper Linux'


    Loading Linux ...



    The setup as following:


    ESXI/ Ubuntu 16.04.1 LTS/

    junos: vqfx10k-pfe-virtualbox-20160609.box


    Any ideas why is not working?


    Thanks Niklas

  • 2.  RE: vqfx10k-pfe is not starting

    Posted 01-23-2017 23:31

    Hi folks,

    What is the CPU and memory resources added to the VM? How many wan interfaces are added to the pfe?

  • 3.  RE: vqfx10k-pfe is not starting

    Posted 01-23-2017 23:55


    Thanks for the quick response.


    I'm using junipers standars setup for the moment (full-1qfx or full-2qfx)


    @vqfx-10000:~$ lscpu
    Architecture: x86_64
    CPU op-mode(s): 32-bit, 64-bit
    Byte Order: Little Endian
    CPU(s): 3
    On-line CPU(s) list: 0-2
    Thread(s) per core: 1
    Core(s) per socket: 3
    Socket(s): 1
    NUMA node(s): 1
    Vendor ID: GenuineIntel
    CPU family: 6
    Model: 63
    Model name: Intel(R) Xeon(R) CPU E5-2620 v3 @ 2.40GHz
    Stepping: 0
    CPU MHz: 2397.223
    BogoMIPS: 4794.44
    Virtualization: VT-x
    Hypervisor vendor: VMware
    Virtualization type: full
    L1d cache: 32K
    L1i cache: 32K
    L2 cache: 256K
    L3 cache: 15360K
    NUMA node0 CPU(s): 0-2
    Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts mmx fxsr sse sse2 ss ht syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology tsc_reliable nonstop_tsc aperfmperf eagerfpu pni pclmulqdq vmx ssse3 fma cx16 pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand hypervisor lahf_lm abm epb tpr_shadow vnmi ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 invpcid xsaveopt dtherm ida arat pln pts



    BR Niklas

  • 4.  RE: vqfx10k-pfe is not starting

    Posted 01-24-2017 09:14

    it could be that the console data is not getting directed to screen.

    when you see the grub menu, press e for “edit” and insert into before or after Root=Label, console=ttyS0 to continue. 

    if it is not completing, you should now be able to see where it is hanging.

    if it says something about insufficient space, check amount of ram allocated, you want 2048mb

  • 5.  RE: vqfx10k-pfe is not starting

    Posted 01-25-2017 13:03


    I will try.

    VM has 16G memory so it should be enought.





  • 6.  RE: vqfx10k-pfe is not starting

    Posted 01-26-2017 22:43


    I have tried to add   console=ttyS0  and after that do ctrl-x to boot the image.

    Unfortunately no more debugs occur.



  • 7.  RE: vqfx10k-pfe is not starting
    Best Answer

    Posted 01-27-2017 00:45

    i still think it could be console related as you should be getting some ouput.


    however, you do not need access via console. the pfe should connect automatic to the RE via the 169.254.0 network on internal bridge, have you tried connnectivity there?

    more detailed ino on that here: https://github.com/Juniper/vqfx10k-vagrant/wiki/Troubleshooting-Guide



  • 8.  RE: vqfx10k-pfe is not starting

    Posted 01-27-2017 01:56


    Is work now.


    The pfe image did start, it was only a display issue as you said.

    The other thing was the bridge between re and pfe.


    Thanks for the supoort

  • 9.  RE: vqfx10k-pfe is not starting

    This message was posted by a user wishing to remain anonymous
    Posted 09-30-2021 08:45
    This message was posted by a user wishing to remain anonymous


    what the issue?
    I have the same problem.

    Thanks for your help.