Switching

 View Only
last person joined: 4 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  EX - QinQ on trunk interface

    Posted 08-30-2017 17:27

    Hello All,

     

    I hope you are doing well. I have a question regarding Juniper EX4200. 

     

    I have an EX4200 with two port-mode trunk interfaces:

    - one facing the customer where I receive many different vlans (10, 20, 30 and 40),

    - another one facing a Juniper MX where the vlans are received in different subinterfaces according to the vlans.

     

    Is there a way to do the following:

     

    - Vlans 30 and 40 pass through as normal single tagged frames.

    - Vlans 10 and 20 have to be encapsulated in another S-VLAN 100, and pass as VLAN 100 to the MX.

     

    How could I configure this in the switch?

     

    I tried configuring vlan 100 with dot1q-tunneling customer-vlans [ 10 20 ], but it won't work. Please take into account both interfaces are trunk.

     

    I understand set ethernet-switching-options dot1q-tunneling ether-type 0x8100 should be configured, so that in the trunk with Juniper MX both single and dual tagged frames can be sent.

     

    Thank you very much for your help



  • 2.  RE: EX - QinQ on trunk interface

    Posted 09-01-2017 22:59

    Hi,

    Please refer to below tech pubs for more details in Q in Q

     

    Understanding Q-in-Q Tunneling on EX Series Switches

     

    Configuring Q-in-Q Tunneling (CLI Procedure)

     

    You can also refer to below KB which has another example  :[KB13544]

     

    EX-series Switch Q-in-Q tunneling configuration

     

     

    Another Sample Config :

     

    user@switch> show configuration vlans qinqvlan
    vlan-id 4001 {
    dot1q-tunneling {
    customer-vlans [ 1-100 201-300 ];
    }
    user@switch> show configuration interfaces
    ge-0/0/11 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan members 4001;
    }
    }
    }
    ge-0/0/12 {
    unit 0 {
    family ethernet-switching {
    port-mode access;
    vlan members 4001;
    }
    }
    }
    ge-0/0/13 {
    unit 0 {
    family ethernet-switching {
    port-mode access;
    vlan members 4001;
    }
    }
    }
    ge-0/0/14 {
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan members 4001;
    }
    }
    }
    user@switch> show ethernet-switching-options
    dot1q-tunneling {
    ether-type 0x9100;
    }

     

     

     

     
    user@switch> show vlans qinqvlan extensive
     
    VLAN: qinqvlan, Created at: Thu Sep 18 07:17:53 2008
    802.1Q Tag: 4001, Internal index: 18, Admin State: Enabled, Origin: Static
    Dot1q Tunneling Status: Enabled
    Customer VLAN ranges:
                         1-100
                         201-300
    Protocol: Port Mode
    Number of interfaces: Tagged 2 (Active = 0), Untagged  4 (Active = 0)
          ge-0/0/11.0, tagged, trunk
          ge-0/0/14.0, tagged, trunk
          ge-0/0/12.0, untagged, access
          ge-0/0/13.0, untagged, access

    [KUDOS PLEASE! If you think I earned it!

    If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]



  • 3.  RE: EX - QinQ on trunk interface

    Posted 09-04-2017 09:26

    Hello.

     

    Thank you for your response. Unfortunately, the links you provide are for basic qinq, and the configuration is also a single qinq vlan on a single interface, which is not the case I described.

     

    Regards.



  • 4.  RE: EX - QinQ on trunk interface

    Posted 09-04-2017 09:42

    Hi,

     

    Have you gone through the KB I have shared?

     

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB13544

     

    Let me know what is the difference you have in requirement and the example listed in KB.

     

    [KUDOS PLEASE! If you think I earned it!

    If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]



  • 5.  RE: EX - QinQ on trunk interface

    Posted 09-04-2017 09:49

    The KB is basic qinq config, one qinq vlan in one interface. The requirement is clearly explained in my initial post: single tagged vlans and vlans that need to be encapsulated in qinq, both received on the same trunk interface.



  • 6.  RE: EX - QinQ on trunk interface

    Posted 11-27-2019 06:46

    Hi,

     

    Did you find answer to your problem? I have the same case on my network.

     

    Regards.



  • 7.  RE: EX - QinQ on trunk interface

    Posted 09-16-2022 11:20
    Though this is a very old post but I think this might help someone like me.

    I have gone through the same problem where I need to allow normal tag vlans to pass through the qinq interface. 

    So I have gone through the below work around.

    First configure your trunk interface as normal.
    set interfaces xe-0/0/0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces xe-0/0/0 unit 0 family ethernet-switching vlan members 100 200 300

    Now add the flexible-vlan-tagging and encapsulation extended-vlan-bridge on the trunk interface to enable Q-in-Q
    set interfaces xe-0/0/0 flexible-vlan-tagging
    set interfaces xe-0/0/0 encapsulation extended-vlan-bridge

    In my case I am using vlan 10 as S-VLAN. To allow the trunk qinq port to encapsulate the qinq tags use the below.
    set interfaces xe-0/0/0 unit 10 vlan-tags outer 0x8100.10


    For the customer facing port you can configure like below:
    set interfaces xe-0/0/1 flexible-vlan-tagging
    set interfaces xe-0/0/1 native-vlan-id 10
    set interfaces xe-0/0/1 encapsulation extended-vlan-bridge
    set interfaces xe-0/0/1 unit 10 vlan-id-list 1-4094
    set interfaces xe-0/0/1 unit 10 input-vlan-map push
    set interfaces xe-0/0/1 unit 10 output-vlan-map pop


    On the VLAN configuration do it like below: 
    set vlans s-vlan-10 interface xe-0/0/0.10
    set vlans s-vlan-10 interface xe-0/0/8.10

    and for normal tag vlan
    set vlans non-qinq-vlan100 vlan-id 100
    set vlans non-qinq-vlan200 vlan-id 200
    set vlans non-qinq-vlan300 vlan-id 300



    If you are still active on this post then please mark answer as solution. If you still have any question then please reply me.

    ------------------------------
    MD SHAHED FARDOUS
    ------------------------------