View Only
last person joined: 3 days ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  SRX240 Upgrade issues

    Posted 08-12-2018 06:00

    Hey all,


    I have 2 SRX240H units that are standalong both doing the same thing where I can't upgrade them past 12.1X44-D60.2


    I had one in production running 12.1X46-D72.2 3 days ago. I rebooted it to enable IPv6 and it never came back.


    set security forwarding-options family inet6 mode flow-based
    request system reboot

    On boot it is saying: 



    panic: Error: Failed to find a valid wired memory profile


    From loader I couldn't get it to boot, so I decided to reinstall it 


    install file:///junos-srxsme-12.1X46-D72.2-domestic.tgz

    It produced:



    loader> install file:///junos-srxsme-12.1X46-D72.2-domestic.tgz
    Target device selected for installation: internal media 
    /kernel data=0xb09064+0x13459c syms=[0x4+0x8ae70+0x4+0xc9858]
    Kernel entry at 0x801000e0 ...
    init regular console
    Primary ICache: Sets 64 Size 128 Asso 4
    Primary DCache: Sets 1 Size 128 Asso 64
    Secondary DCache: Sets 512 Size 128 Asso 8
    GDB: debug ports: uart
    GDB: current port: uart
    KDB: debugger backends: ddb gdb
    KDB: current backend: ddb
    kld_map_v: 0x8ff80000, kld_map_p: 0x0
    panic: Error: Failed to find a valid wired memory profile
    cpuid = 0
    KDB: stack backtrace:
    SP 0: not in kernel
    uart_z8530_class+0x0 (0,0,0,0) ra 0 sz 0
    pid 0, process: 
    KDB: enter: panic
    [thread pid 0 tid 0 ]
    Stopped at      breakpoint+0x4: jr      ra

    To skip a whole bunch of code, the only one that worked was junos-srxsme-12.1X44-D60.2-domestic.tgz


    I can boot that version fine. But from Junos or loader, I can't load any other version above that one, not even junos-srxsme-12.1X45-D10-domestic.tgz

    I also tried (from Junos) 

    request system software add /tmp/usb/junos-srxsme-12.1X45-D10-domestic.tgz no-copy no-validate partition

    And same error on boot (Failed to find a valid wired memory profile)


    So I have no idea what I'm doing wrong or why I can't upgrade these units.

    Whilst they are Just the SRX240H (not the H2) they do have 2GB memory so they should be supported (according to and through to 12.1X46-D77


    Any ideas or help appreciated. 


  • 2.  RE: SRX240 Upgrade issues
    Best Answer

    Posted 08-12-2018 11:07

    Hi, if your SRX240H's has 2 GB of RAM, they have been modified as SRX240H is only a 1G platform. Some people has tried to upgrade with 2 GB of memory - some with luck, other not.


    Please validate that you actually have two SRX240's with 2G RAM. If so, then it's quite unsupported and difficult to help.


    Ref. - especially some of the comments.



  • 3.  RE: SRX240 Upgrade issues

    Posted 08-12-2018 19:50

    A script has been updated to prevent users from 2G branch-series platforms from upgrading to 12.1X46-D66 and later releases through PR 1264117.


    Hence your upgrade fails. Please review the following TSB17084 for more informatoin:


    12.1X46-D65 is the final maintenance release in 12.1X46 that is available for the 2GB RAM H/w.






  • 4.  RE: SRX240 Upgrade issues

    Posted 08-14-2018 04:11

    Hey All


    Karan, I don't think that is the case. That article is saying that support for 1GB models is extended, not stopped


    Jonas, you hit the nail on the head.

    Whilst the 2GB is unsupported, it works with the older releases. 

    I rolled back to the 1GB and it worked perfectly for the upgrades........ here is the kicker but

    After the upgrade is done (12.1X46-D60) I popped the 2GB back in, and it worked perfectly. 3 reboots later and its working fine still. 


    I have a feeling something is doing a check on the memory on boot and halting it in some situations.


    So for anyone who finds this later, its yeah, a memory issue.