Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Juniper NAT transition from MS-MPC single PIC to AMS configs for load-balancing

This thread has been viewed 1 times
  • 1.  Juniper NAT transition from MS-MPC single PIC to AMS configs for load-balancing

    Posted 06-27-2022 10:05

    I have an MX-960 being used as a BRAS/BNG for PPPoE subscribers using deterministic NAT IPv4. The current configs are shared below. I tried deleting all configs under ms-2/0/0 and copying it to under ams0 using the redundancy-options (as mentioned here https://www.juniper.net/documentation/us/en/software/junos/interfaces-adaptive-services/topics/topic-map/load-balance-high-avail-AMS.html#id-configuring-warm-standby-for-services-interfaces ). And in the service set settings I tried changing ms-2/0/0 to ams0.

    Yet I get the errors below:

    error: Check-out failed for Mobility process (/usr/sbin/mobiled) without details
    error: configuration check-out failed

    If anyone has experience with this sort of thing, please assist me. What am I missing. I was thinking of doing this as a first step i.e. this warm stand-by thing where one PIC is active and the other is backup and then I thought I would move to the load-balancing options.

    Thanks in advance.

    services-options {
        open-timeout 5;
        close-timeout 5;
        inactivity-tcp-timeout 300;
        inactivity-asymm-tcp-timeout 300;
        inactivity-non-tcp-timeout 30;
        tcp-tickles 4;
        fragment-limit 10;
        reassembly-timeout 3;
    }
    unit 0 {
        description "interface for service-set SP000";
        no-traps;
        family inet {
            address 10.30.9.50/32;
        }
    }
    unit 1 {
        description "Inside interface for service-set SP000";
        no-traps;
        family inet;
        service-domain inside;
    }
    unit 2 {
        description "Outside interface for service-set SP000";
        no-traps;
        family inet;
        service-domain outside;
    

    syslog {
        host 192.168.54.27 {
            inactive: services info;
            log-prefix ISB-Session;
            source-address 10.30.9.5;
        }
    }
    nat-rules sp000;
    interface-service {
        service-interface ms-2/0/0;

    shahbaz@ISB-BNG-MX96-1-re0> show configuration interfaces ae4 
    description wd-MX960-ISB-Router;
    aggregated-ether-options {
        lacp {
            active;
        }
    }
    unit 0 {
        family inet {
            inactive: filter {
                output web-filter2;
            }
            service {
                input {
                    service-set sp000;
                }
                output {
                    service-set sp000;
                }
            }
            address 10.30.9.2/30;
        }
        family inet6 {
            address 2407:9e00::b4a5:2/112;
        }
    }


    ------------------------------
    shazzy
    ------------------------------