Routing

  • 1.  OSPFv3 assistance needed

    Posted 02-27-2021 19:45
    I have the following topology
    Area 3 is linked to area 0 via GRE tunnels.
    From R2, I have the following:

    lab@mxB# run traceroute 182.10.128.1 logical-system R2   

    traceroute to 182.10.128.1 (182.10.128.1), 30 hops max, 52 byte packets

     1  172.17.23.14 (172.17.23.14)  1.714 ms  1.511 ms  1.224 ms

     2  172.30.0.130 (172.30.0.130)  2.033 ms  2.230 ms  1.885 ms

     3  182.10.128.1 (182.10.128.1)  1.969 ms  2.128 ms  2.052 ms

    It goes through R4, it is not optimal path, right ?

    I was told to do the following:

    lab@R1# show | display set | match restrict

    set protocols ospf3 realm ipv4-unicast area 0.0.0.2 area-range 172.17.20.1/32 restrict

    set protocols ospf3 area 0.0.0.2 area-range 2002:172:17:20::1/128 restrict

    But after I gave a try, it did not change anything.

    Anyone can give me some insights on this ?

    thanks so so much in advance !!!


    All the configuration

    R1

    set interfaces ge-0/0/0 unit 0 family inet address 172.17.23.1/30

    set interfaces ge-0/0/0 unit 0 family inet6 address 2006:17::1/126

    set interfaces ge-0/0/1 unit 0 family inet address 172.17.23.5/30

    set interfaces ge-0/0/1 unit 0 family inet6 address 2006:17::5/126

    set interfaces ge-0/0/2 unit 0 family inet address 10.1.0.2/30

    set interfaces ge-0/0/2 unit 0 family inet6 address 2005:10::2/64

    set interfaces lo0 unit 1 family inet address 172.17.20.1/32

    set interfaces lo0 unit 1 family inet6 address 2002:172:17:20::1/128

     

    set protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface ge-0/0/2.0 interface-type p2p

    set protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface gr-0/0/10.1 interface-type p2p

    set protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface gr-0/0/10.0 interface-type p2p

    set protocols ospf3 realm ipv4-unicast area 0.0.0.2 area-range 172.17.20.1/32 restrict

    set protocols ospf3 realm ipv4-unicast area 0.0.0.2 interface ge-0/0/0.0 interface-type p2p

    set protocols ospf3 realm ipv4-unicast area 0.0.0.2 interface ge-0/0/1.0 interface-type p2p

    set protocols ospf3 realm ipv4-unicast area 0.0.0.2 interface lo0.1 passive

    set protocols ospf3 area 0.0.0.3 interface ge-0/0/2.0 interface-type p2p

    set protocols ospf3 area 0.0.0.3 interface gr-0/0/10.0 interface-type p2p

    set protocols ospf3 area 0.0.0.3 interface gr-0/0/10.1 interface-type p2p

    set protocols ospf3 area 0.0.0.2 area-range 2002:172:17:20::1/128 restrict

    set protocols ospf3 area 0.0.0.2 interface ge-0/0/0.0 interface-type p2p

    set protocols ospf3 area 0.0.0.2 interface ge-0/0/1.0 interface-type p2p

    set protocols ospf3 area 0.0.0.2 interface lo0.1 passive

    set chassis fpc 0 pic 0 tunnel-services bandwidth 1g 

    set interfaces gr-0/0/10 unit 0 tunnel source 172.17.20.1

    set interfaces gr-0/0/10 unit 0 tunnel destination 172.17.20.4

    set interfaces gr-0/0/10 unit 0 family inet address 172.30.0.130/30

    set interfaces gr-0/0/10 unit 0 family inet6 address 2007:30::82/126 

    set interfaces gr-0/0/10 unit 1 tunnel source 172.17.20.1

    set interfaces gr-0/0/10 unit 1 tunnel destination 172.17.20.5

    set interfaces gr-0/0/10 unit 1 family inet address 172.30.0.134/30

    set interfaces gr-0/0/10 unit 1 family inet6 address 2007:30::86/126

     

    set routing-options static route 172.17.20.4/32 next-hop 172.17.23.2

    set routing-options static route 172.17.20.5/32 next-hop 172.17.23.6

     

    C1

    set routing-instances C1 instance-type virtual-router

    set routing-instances C1 protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface ge-0/0/0.0 interface-type p2p

    set routing-instances C1 protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface lo0.1 passive

    set routing-instances C1 protocols ospf3 area 0.0.0.3 interface lo0.1 passive

    set routing-instances C1 protocols ospf3 area 0.0.0.3 interface ge-0/0/0.0 interface-type p2p

    set routing-instances C1 interface ge-0/0/0.0

    set routing-instances C1 interface lo0.1

     

    set interfaces ge-0/0/0 unit 0 family inet address 10.1.0.1/30

    set interfaces ge-0/0/0 unit 0 family inet6 address 2004:10::1/64

    set interfaces lo0 unit 1 family inet address 10.1.20.1/32

    set interfaces lo0 unit 1 family inet address 182.10.128.1/24

    set interfaces lo0 unit 1 family inet address 182.10.129.1/24

    set interfaces lo0 unit 1 family inet address 182.10.130.1/24

    set interfaces lo0 unit 1 family inet address 182.10.131.1/24

    mxB

    set logical-systems R2 interfaces ge-0/0/0 unit 0 family inet address 172.17.23.2/30

    set logical-systems R2 interfaces ge-0/0/0 unit 0 family inet6 address 2006:17::2/126

    set logical-systems R2 interfaces ge-0/0/0 unit 0 family mpls

    set logical-systems R2 interfaces ge-0/0/2 unit 0 family inet address 172.17.23.9/30

    set logical-systems R2 interfaces ge-0/0/2 unit 0 family inet6 address 2006:17::9/126

    set logical-systems R2 interfaces ge-0/0/2 unit 0 family mpls

    set logical-systems R2 interfaces ge-0/0/4 unit 0 family inet address 172.17.23.13/30

    set logical-systems R2 interfaces ge-0/0/4 unit 0 family inet6 address 2006:17::d/126

    set logical-systems R2 interfaces ge-0/0/4 unit 0 family mpls

    set logical-systems R2 interfaces lo0 unit 2 family inet address 172.17.20.2/32

    set logical-systems R2 protocols ospf3 realm ipv4-unicast area 0.0.0.2 interface ge-0/0/0.0 interface-type p2p

    set logical-systems R2 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/2.0 interface-type p2p

    set logical-systems R2 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/4.0 interface-type p2p

    set logical-systems R2 protocols ospf3 area 0.0.0.2 interface ge-0/0/0.0 interface-type p2p

    set logical-systems R2 protocols ospf3 area 0.0.0.0 interface ge-0/0/4.0 interface-type p2p

    set logical-systems R2 protocols ospf3 area 0.0.0.0 interface ge-0/0/2.0 interface-type p2p

     

    set logical-systems R3 interfaces ge-0/0/1 unit 0 family inet address 172.17.23.6/30

    set logical-systems R3 interfaces ge-0/0/1 unit 0 family inet6 address 2006:17::6/126

    set logical-systems R3 interfaces ge-0/0/3 unit 0 family inet address 172.17.23.10/30

    set logical-systems R3 interfaces ge-0/0/3 unit 0 family inet6 address 2006:17::a/126

    set logical-systems R3 interfaces ge-0/0/5 unit 0 family inet address 172.17.23.17/30

    set logical-systems R3 interfaces ge-0/0/5 unit 0 family inet6 address 2006:17::11/126

    set logical-systems R3 interfaces lo0 unit 3 family inet address 172.17.20.3/32

    set logical-systems R3 protocols ospf3 realm ipv4-unicast area 0.0.0.2 interface ge-0/0/1.0 interface-type p2p

    set logical-systems R3 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p

    set logical-systems R3 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/5.0 interface-type p2p

    set logical-systems R3 protocols ospf3 area 0.0.0.2 interface ge-0/0/1.0 interface-type p2p

    set logical-systems R3 protocols ospf3 area 0.0.0.0 interface ge-0/0/5.0 interface-type p2p

    set logical-systems R3 protocols ospf3 area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p

    mxC

    set logical-systems R4 interfaces ge-0/0/0 unit 0 family inet address 172.17.23.25/30

    set logical-systems R4 interfaces ge-0/0/2 unit 0 family inet address 172.17.23.21/30

    set logical-systems R4 interfaces ge-0/0/2 unit 0 family inet6 address 2006:17::15/126

    set logical-systems R4 interfaces ge-0/0/4 unit 0 family inet address 172.17.23.14/30

    set logical-systems R4 interfaces ge-0/0/4 unit 0 family inet6 address 2006:17::e/126

    set logical-systems R4 interfaces gr-0/0/10 unit 0 tunnel source 172.17.20.4

    set logical-systems R4 interfaces gr-0/0/10 unit 0 tunnel destination 172.17.20.1

    set logical-systems R4 interfaces gr-0/0/10 unit 0 family inet address 172.30.0.129/30

    set logical-systems R4 interfaces gr-0/0/10 unit 0 family inet6 address 2007:30::81/126

    set logical-systems R4 interfaces lo0 unit 4 family inet address 172.17.20.4/32

    set logical-systems R4 interfaces lo0 unit 4 family inet6

    set logical-systems R4 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/4.0 interface-type p2p

    set logical-systems R4 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/2.0 interface-type p2p

    set logical-systems R4 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.4 passive

    set logical-systems R4 protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface gr-0/0/10.0 interface-type p2p

    set logical-systems R4 protocols ospf3 area 0.0.0.0 interface ge-0/0/2.0 interface-type p2p

    set logical-systems R4 protocols ospf3 area 0.0.0.0 interface ge-0/0/4.0 interface-type p2p

    set logical-systems R4 protocols ospf3 area 0.0.0.0 interface lo0.4 passive

    set logical-systems R4 protocols ospf3 area 0.0.0.3 interface gr-0/0/10.0 interface-type p2p

    set logical-systems R4 routing-options static route 172.17.20.1/32 next-hop 172.17.23.13

     

    set logical-systems R5 interfaces ge-0/0/1 unit 0 family inet address 172.17.23.29/30

    set logical-systems R5 interfaces ge-0/0/3 unit 0 family inet address 172.17.23.22/30

    set logical-systems R5 interfaces ge-0/0/3 unit 0 family inet6 address 2006:17::16/126

    set logical-systems R5 interfaces ge-0/0/5 unit 0 family inet address 172.17.23.18/30

    set logical-systems R5 interfaces ge-0/0/5 unit 0 family inet6 address 2006:17::12/126

    set logical-systems R5 interfaces gr-0/0/10 unit 1 tunnel source 172.17.20.5

    set logical-systems R5 interfaces gr-0/0/10 unit 1 tunnel destination 172.17.20.1

    set logical-systems R5 interfaces gr-0/0/10 unit 1 family inet address 172.30.0.133/30

    set logical-systems R5 interfaces gr-0/0/10 unit 1 family inet6 address 2007:30::85/30

    set logical-systems R5 interfaces lo0 unit 5 family inet address 172.17.20.5/32

    set logical-systems R5 interfaces lo0 unit 5 family inet6

    set logical-systems R5 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/5.0 interface-type p2p

    set logical-systems R5 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p

    set logical-systems R5 protocols ospf3 realm ipv4-unicast area 0.0.0.0 interface lo0.5 passive

    set logical-systems R5 protocols ospf3 realm ipv4-unicast area 0.0.0.3 interface gr-0/0/10.1 interface-type p2p

    set logical-systems R5 protocols ospf3 area 0.0.0.0 interface lo0.5 passive

    set logical-systems R5 protocols ospf3 area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p

    set logical-systems R5 protocols ospf3 area 0.0.0.0 interface ge-0/0/5.0 interface-type p2p

    set logical-systems R5 protocols ospf3 area 0.0.0.3 interface gr-0/0/10.1 interface-type p2p

    set logical-systems R5 routing-options static route 172.17.20.1/32 next-hop 172.17.23.17