Switching

Expand all | Collapse all

EX4600 no-auto-negotiation

  • 1.  EX4600 no-auto-negotiation

    Posted 01-19-2021 06:13

    Hi,

    I'm trying to connect an old Cisco switch to a new EX4600, but the link won't come up.
    The Cisco port is configured with "switchport nonegociate" and in 100/full (parameters I can't change on the Cisco).
    I've tried both :
    ether-options {
    no-auto-negotiation;
    }
    and
    gigether-options {
    no-auto-negotiation;
    }
    on the EX4600 but the link is still down.

    Physical interface: ge-0/0/9, Enabled, Physical link is Down
    Interface index: 685, SNMP ifIndex: 598
    Link-level type: Ethernet, MTU: 1514, LAN-PHY mode, Speed: 1000mbps, BPDU Error: None, Loop Detect PDU Error: None, Ethernet-Switching Error: None, MAC-REWRITE Error: None, Loopback: Disabled,
    Source filtering: Disabled, Flow control: Disabled, Auto-negotiation: Disabled, Remote fault: Online, Media type: Fiber
    Device flags : Present Running Down
    Interface flags: Hardware-Down SNMP-Traps Internal: 0x4000
    Link flags : None
    CoS queues : 12 supported, 12 maximum usable queues
    Current address: 94:bf:94:57:2e:0c, Hardware address: 94:bf:94:57:2e:0c
    Last flapped : 2021-01-19 11:53:13 CET (00:11:37 ago)
    Input rate : 0 bps (0 pps)
    Output rate : 0 bps (0 pps)
    Active alarms : LINK
    Active defects : LINK

    Any idea ?

    Regards
    Steph

    ------------------------------
    STEPHANE ARDHUIN
    ------------------------------


  • 2.  RE: EX4600 no-auto-negotiation

     
    Posted 01-19-2021 17:17
    You will also need to add to ether options full duplex 100m in addition to the no-auto

    set interfaces ge-0/0/1 ether-options no-auto-negotiation

    set interfaces ge-0/0/1 ether-options link-mode full-duplex

    set interfaces ge-0/0/1 ether-options speed 100m



    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: EX4600 no-auto-negotiation

    Posted 01-20-2021 03:36
    thank you Steve, 
    I already have the following lines : 
    set interfaces ge-0/0/9 speed 100m
    set interfaces ge-0/0/9 link-mode full-duplex
    set interfaces ge-0/0/9 ether-options no-auto-negotiation
    set interfaces ge-0/0/9 gigether-options no-auto-negotiation
    set interfaces ge-0/0/9 unit 0 family ethernet-switching

    I've tested it on a lab switch the 100/full part is OK.  But when I add the "switchport nonegociate" on the Cisco the link goes down.

    ------------------------------
    STEPHANE ARDHUIN
    ------------------------------



  • 4.  RE: EX4600 no-auto-negotiation

     
    Posted 01-20-2021 05:41
    Can you verify the actual settings on the port using the media check option
    show interfaces ge-0/0/9 media

    I also wonder by you have both no-auto options on, I have only ever used one before.

    These FE connections with Cisco are always a pain.  Too bad you can't just turn it off on the Cisco side since you see that will work.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 5.  RE: EX4600 no-auto-negotiation

     
    Posted 01-20-2021 06:43
    Hello Stephane,

    as I can see this is a fiber 100M connection. Can you please advise which SFPs exactly you have inserted? You need 100m capable transceivers on both sides. As I can see the EX4600 detects them as 1G, so please confirm these are 100M/1G multirate SFPs which are inserted.

    Additionally, please inform which JUNOS release is installed. There are older releases which are very sensitive regarding 100M speed. If you have an old image, try to upgrade to a newer image first.

    Please check the Rx and Tx light levels on both sides as well.
    Juniper: show interfaces diagnostics optics ge-0/0/1
    Cisco: show interface <IF number> transceiver details


    As Steve already mentioned, please configure just these 3 lines on the EX:

    set interfaces ge-0/0/1 ether-options no-auto-negotiation

    set interfaces ge-0/0/1 ether-options link-mode full-duplex

    set interfaces ge-0/0/1 ether-options speed 100m


    You do not need to configure the "gigether-options" for this.



    ------------------------------
    ------------------------------
    If my answer provides the solution, please mark my post as "Best Answer".
    If you think my answer helps, please "Recommend" my post.
    ------------------------------



  • 6.  RE: EX4600 no-auto-negotiation

    Posted 01-20-2021 08:08
    Thank you both for your replies,

    I've tried both no-auto options separately and together but it makes no difference. 

    I've noticed that the media type says fiber even though the transceiver is a Base-T module (740-013111). I've tried to change the SFP but no luck.
    I can't find a command to force it to copper. The "set interface ge-0/0/9 media-type" command doesn't exist.

    The version is Junos: 18.1R3-S6.1

    Physical interface: ge-0/0/9, Enabled, Physical link is Down
    Interface index: 685, SNMP ifIndex: 598
    Link-level type: Ethernet, MTU: 1514, LAN-PHY mode, Speed: 1000mbps, BPDU Error: None, Loop Detect PDU Error: None, Ethernet-Switching Error: None, MAC-REWRITE Error: None, Loopback: Disabled,
    Source filtering: Disabled, Flow control: Disabled, Auto-negotiation: Disabled, Remote fault: Online, Media type: Fiber
    Device flags : Present Running Down
    Interface flags: Hardware-Down SNMP-Traps Internal: 0x4000
    Link flags : None
    CoS queues : 12 supported, 12 maximum usable queues
    Current address: 94:bf:94:57:2e:0c, Hardware address: 94:bf:94:57:2e:0c
    Last flapped : 2021-01-19 11:53:13 CET (23:57:22 ago)
    Input rate : 0 bps (0 pps)
    Output rate : 0 bps (0 pps)
    Active alarms : LINK
    Active defects : LINK
    PCS statistics Seconds
    Bit errors 0
    Errored blocks 0
    Ethernet FEC statistics Errors
    FEC Corrected Errors 0
    FEC Uncorrected Errors 0
    FEC Corrected Errors Rate 0
    FEC Uncorrected Errors Rate 0
    MAC statistics:
    Input bytes: 0, Input packets: 0, Output bytes: 0, Output packets: 0
    Filter statistics:
    Filtered packets: 0, Padded packets: 0, Output packet errors: 0
    Autonegotiation information:
    Negotiation status: Incomplete
    Interface transmit statistics: Disabled

    ------------------------------
    STEPHANE ARDHUIN
    ------------------------------



  • 7.  RE: EX4600 no-auto-negotiation

    Posted 01-20-2021 08:28
    Stephane.. would you please post
    show chassis hardware | match PIC

    Only reason. My 4600 only supports 10gig only on pic0 and i had to buy expansion mods to support 1gig  EX4600-EM-8F, and Ive never tried to setup a 100m ..  

    One other thing to try as a shot in the dar on ge-0/0/9 sorry if you already have .
    set ether-options no-auto-mdix


  • 8.  RE: EX4600 no-auto-negotiation

    Posted 01-20-2021 08:59
    Yes the PIC says 10G :
    PIC 0 BUILTIN BUILTIN 24x10G-4x40G
    I guess it is the maximum speed
    I have several connexions on PIC 0 at 1G. I have also configured a 100/full connexion successfully with the auto-neg on.
    It is really the disabled auto-neg on the Cisco side that seems to be the problem here. 

    I just tried the no-auto-mdix but unfortunately it that change anything.

    ------------------------------
    STEPHANE ARDHUIN
    ------------------------------



  • 9.  RE: EX4600 no-auto-negotiation

     
    Posted 01-20-2021 08:53
    Although I cannot find the PR now, this "Media Type: Fiber" thing is a known cosmetic issue and fixed in newer versions.

    I have found a similar PR which could affect you:
    https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1437577

    Can you please try an upgrade to a fixed release and check again?

    ------------------------------
    ------------------------------
    If my answer provides the solution, please mark my post as "Best Answer".
    If you think my answer helps, please "Recommend" my post.
    ------------------------------



  • 10.  RE: EX4600 no-auto-negotiation

    Posted 01-20-2021 09:02

    Bonjour StephA,

     

                   When trying to connect my Juniper EX2300 to a 100m full duplex no-negotiate device interface, it took me a while to figure that not only do I have tell my Juniper to speed 100 and link-mode full duplex but I also have to specify the ether option non negotiate. Just telling the switch speed and mode is not enough.

    Good luck,

     

    __________________________________________

    Michel Lapointe