Security Management

Expand all | Collapse all

STRM-VM WebUI

Jump to Best Answer
  • 1.  STRM-VM WebUI

    Posted 03-13-2018 14:34

    Hi

     

    i have installed a new STRM-VM machine but I can access it only via SSH ...

    Is there any way\option to enable the WebUI access or special URI ?



  • 2.  RE: STRM-VM WebUI

    Posted 03-13-2018 21:04

    Hi Abed,

     

    Kindly refer below docuemnt and page number 19 for webUI 

     

     https://www.juniper.net/documentation/software/management/strm/2013_2/strm-va-installation-guide.pdf

     

    When you access the STRM user interface for the first time, note the following requirements:

    • If you use Mozilla Firefox, you must add an exception to Mozilla Firefox. For more information, see your Mozilla documentation.

    • If you use Internet Explorer, a website security certificate message is displayed.

    You must select the Continue to this website option to log in to STRM.

    • For your STRM Console, a default license key provides you access to STRM for five weeks.

    For more information on the license key, see the STRM Administration Guide.

     

    Procedure: 

     

    Step 1 Open your web browser.

     

    Step 2 Log in to STRM: https:// Where is the IP address of the STRM system.

    The default values are: Username: admin Password:

     

    Step 3 Click Login To STRM.


    Hope this helps
    --------------------------------------------------------------------------------------------------------
    If this post was helpful, please mark this post as an "Accepted Solution".
    Kudos are always appreciated!
    --------------------------------------------------------------------------------------------------------



  • 3.  RE: STRM-VM WebUI

     
    Posted 03-13-2018 22:24

    Hi Abed,

     

    As such there is no extra step to enable webUI, just a normal URL https://<IP>

    Which version you deployed.

     

    Check the service:

    service tomcat status

     

    Paste the output for: cat /etc/hosts

     

    -PL



  • 4.  RE: STRM-VM WebUI

    Posted 03-14-2018 01:09
    [root@strmv-ma ~]# service tomcat status
    tomcat is stopped
    [root@strmv-ma ~]# service tomcat start
    This is not a console; do not manage tomcat                [  OK  ]
    [root@strmv-ma ~]# service tomcat status
    tomcat is stopped
    [root@strmv-ma ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain localhost
    172.21.26.100   strmv-ma.kis.co strmv-ma
    

     I have deployed : 2012.1.R1 iso



  • 5.  RE: STRM-VM WebUI

     
    Posted 03-14-2018 02:55

    From the output it seem that this is not a console server.

    What deployment you have selected while setting up this server?

    Can you provide the output for:  

    cat /etc/.appliance_name



  • 6.  RE: STRM-VM WebUI

    Posted 03-14-2018 03:45
    I have deployed it again , and now I installed the STRM2013.1.r3 iso file

    [root@strmrvd ~]# cat /etc/.appliance_name
    3199
    [root@strmrvd ~]# service tomcat status
    tomcat (pid 21274) is running...

    but still don't have webui access ... only ssh


  • 7.  RE: STRM-VM WebUI

    Posted 03-14-2018 03:56
    in SRX shows that it responds to 443 .. but no webui access


    admin@SRX550-DC-SH> show security flow session destination-prefix 172.21.26.100
    Session ID: 2876, Policy name: STRMV/92, Timeout: 1796, Valid
    In: 1.1.1.1/35020 --> 172.21.26.100/443;tcp, If: ge-0/0/3.0, Pkts: 3, Bytes: 649
    Out: 172.21.26.100/443 --> 1.1.1.1/35020;tcp, If: ae1.1865, Pkts: 2, Bytes: 92


  • 8.  RE: STRM-VM WebUI

     
    Posted 03-14-2018 04:09

    Hi Abed,

     

    You can check log file:

     

    /var/log/qradar.log

    /var/log/qradar.error

     

    -PL



  • 9.  RE: STRM-VM WebUI

    Posted 03-14-2018 04:29

    Is this option valid for https access ? if not , then which one ?

     

    Capture.PNG

     



  • 10.  RE: STRM-VM WebUI
    Best Answer

     
    Posted 03-14-2018 04:33

    Earlier you have installed 3199 which is All-in-one that will also work on https only.

    3199 is valid one for you.



  • 11.  RE: STRM-VM WebUI

    Posted 03-14-2018 04:35
    and thats what i did earlier .. yes
    let me go again step by step and then update you
    just to confirm , do I need to configure any special configuration in order to get https access?


  • 12.  RE: STRM-VM WebUI

     
    Posted 03-14-2018 04:42

    Hi Abed,

    Why don't go to some latest version i.e. 2014.8 rather than 2013

     

    While deploying name of the STRM/JSA should be in FQDN i.e. jsa.jnpr.net no other configuration is required for https.



  • 13.  RE: STRM-VM WebUI

    Posted 03-14-2018 05:06
    Hi
    At first I went with the recommended version ..
    Then I went with the same version we have on a physical STRM machine we already have which is working fine (2013R1)
    But still with the strm virtual machine no https access .. only ssh .. not sure what should I see in the qradar log file


  • 14.  RE: STRM-VM WebUI

    Posted 03-14-2018 05:16
    It is working now!! 🙂
    I've tried webui access from another PC ..
    Not sure why .. because firefiox version is same on both PCs .. but sure i'll try to troubleshoot that later .. now moving to next step
    Thanks PML!


  • 15.  RE: STRM-VM WebUI

    Posted 03-14-2018 09:37

    Hi PML

     

    New issue has been observed .. every 2-3 minutes the https stuck and this error message shows up:

     

    Capture.PNG

     

    The thing is no network issue .. and SSH continue working fine ..

    Is this a known issue ?

     

     



  • 16.  RE: STRM-VM WebUI

     
    Posted 03-14-2018 10:17
    What version you are using?
    What is the memory allocated?


  • 17.  RE: STRM-VM WebUI

    Posted 03-14-2018 11:24

    2013.1.r3
    8GB Memory
    2X4 CPU



  • 18.  RE: STRM-VM WebUI

     
    Posted 03-14-2018 22:27

    2013.2 should run on 8GB memory but you can check memory utilisation of the server.

    As such I am not aware of any known issue, we can check on IBM site if any.

    The web ui is in constant communication with the console via the web service httpd and tomcat, running over port 443 so we can check if 443 connection is getting dropped.



  • 19.  RE: STRM-VM WebUI

     
    Posted 03-14-2018 22:33

    You can try using different browser as well, it could be browser issue as well.