Junos OS

Expand all | Collapse all

login issues after junos os upgrade to v20.2r3

  • 1.  login issues after junos os upgrade to v20.2r3

    Posted 15 days ago
    HI Elevate Community,

    Is there anyone here had login credential issues on their SRX devices after upgrading to recommended version 20.2r3?

    Seemed that logging to console and ssh with any valid local admin accounts is not possible.

    Error says, invalid login,credentials etc. Console output looked normal;

    My option is to do root recovery but Im prompted with the GRUB menu instead of the valid prompt where I can issue boot -s command.

    Please share your experience.

    Leangf

    ------------------------------
    Leangf Leangf
    ------------------------------


  • 2.  RE: login issues after junos os upgrade to v20.2r3

    Posted 12 days ago
    Hi,

    what was the version that you used before?
    is it just local admins or also the root-account?
    Normally an upgrade should always work - downgrade (due to changed hashes) is a different story ;)

    Maybe the primary partition crashed due to the update, resulting in loading an old (outdated) saved rescue config - did the password change at any point in time?

    christian


    ------------------------------
    Christian Scholz
    Juniper Networks Ambassador | JNCIE-SEC #374
    Mail: chs@ip4.de
    Blog: jncie.eu | Twitter: @chsjuniper | YT-Channel: netchron
    ------------------------------



  • 3.  RE: login issues after junos os upgrade to v20.2r3

    Posted 16 minutes ago
    If you had previously configured
    set system login password format sha1
    then you might hit PR1571179, which says:
    «SHA-1 system login password format not accepted post upgrade»


    ------------------------------
    OLIVIER BENGHOZI
    ------------------------------