Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

login issues after junos os upgrade to v20.2r3

  • 1.  login issues after junos os upgrade to v20.2r3

    Posted 07-10-2021 04:19
    HI Elevate Community,

    Is there anyone here had login credential issues on their SRX devices after upgrading to recommended version 20.2r3?

    Seemed that logging to console and ssh with any valid local admin accounts is not possible.

    Error says, invalid login,credentials etc. Console output looked normal;

    My option is to do root recovery but Im prompted with the GRUB menu instead of the valid prompt where I can issue boot -s command.

    Please share your experience.

    Leangf

    ------------------------------
    Leangf Leangf
    ------------------------------


  • 2.  RE: login issues after junos os upgrade to v20.2r3

    Posted 07-12-2021 19:04
    Hi,

    what was the version that you used before?
    is it just local admins or also the root-account?
    Normally an upgrade should always work - downgrade (due to changed hashes) is a different story ;)

    Maybe the primary partition crashed due to the update, resulting in loading an old (outdated) saved rescue config - did the password change at any point in time?

    christian


    ------------------------------
    Christian Scholz
    Juniper Networks Ambassador | JNCIE-SEC #374
    Mail: chs@ip4.de
    Blog: jncie.eu | Twitter: @chsjuniper | YT-Channel: netchron
    ------------------------------



  • 3.  RE: login issues after junos os upgrade to v20.2r3

    Posted 07-26-2021 05:22
    Hi Christian,

    what was the version that you used before?   --- 19.4R3 

    is it just local admins or also the root-account?  --local root account (console, ssh, https)

    Normally an upgrade should always work - downgrade (due to changed hashes) is a different story ;)
          >yes, as this is a standard across juniper devices. I never encountered such issues before.

    Maybe the primary partition crashed due to the update, resulting in loading an old (outdated) saved rescue config - did the password change at any point in time?
         >no password changes as we control the root access via console. Im not sure if I can reset it via console as these units were located in a data center.
          going on-site is a challenge though.

    Thank you.
    Leangf

    ------------------------------
    Leangf Leangf
    ------------------------------



  • 4.  RE: login issues after junos os upgrade to v20.2r3

    Posted 07-25-2021 05:32
    If you had previously configured
    set system login password format sha1
    then you might hit PR1571179, which says:
    «SHA-1 system login password format not accepted post upgrade»


    ------------------------------
    OLIVIER BENGHOZI
    ------------------------------



  • 5.  RE: login issues after junos os upgrade to v20.2r3

    Posted 07-26-2021 05:23
    Hi Olivier,

    Just the default ssh configured, no special keys set.

    Im not sure what happened after the upgrade from 19.4r3 to 20.2r3 which is the recommended for SRX1500 device.

    My option is to reload the image on the device from the scratch.


    Thank you.
    Leangf

    ------------------------------
    Leangf Leangf
    ------------------------------