Junos OS

Expand all | Collapse all

MX204, unable to change port speed 40G/100G

  • 1.  MX204, unable to change port speed 40G/100G

    Posted 12-02-2020 09:56

    Hi!

    I'm configuring ports on an MX204 router.
    But, I can't configuring port speed:

    # show chassis  
    fpc 0 {
       pic 0 {
           port 0 {
               speed 100g;
           }
           port 1 {
               speed 100g;
           }
           port 2 {
               speed 40g;
           }
           port 3 {
               speed 40g;
           }
       }

    I executed "commit"...

    but...

    # run show interfaces et-0/0/0   
    Physical interface: et-0/0/0, Enabled, Physical link is Down
     Interface index: 149, SNMP ifIndex: 581
     Link-level type: Ethernet, MTU: 1518, MRU: 1526, Speed: 100Gbps


    # run show interfaces et-0/0/1     
    Physical interface: et-0/0/1, Enabled, Physical link is Down
     Interface index: 150, SNMP ifIndex: 582
     Link-level type: Ethernet, MTU: 1518, MRU: 1526, Speed: 40Gbps


    I have the same
    MX204 and it has a similar problem:

    # show chassis                                 
    fpc 0 {
       pic 0 {
           port 0 {
               speed 100g;
           }
           port 1 {
               speed 40g;
           }
           port 2 {
               speed 40g;
           }
           port 3 {
               speed 40g;
           }

    but...

    # run show interfaces et-0/0/0     
    Physical interface: et-0/0/0, Enabled, Physical link is Down
     Interface index: 148, SNMP ifIndex: 552
     Link-level type: Ethernet, MTU: 1518, MRU: 1526, Speed: 100Gbps,

     
    # run show interfaces et-0/0/1     
    Physical interface: et-0/0/1, Enabled, Physical link is Down
     Interface index: 149, SNMP ifIndex: 553
     Link-level type: Ethernet, MTU: 1518, MRU: 1526, Speed: 100Gbps,


    I'm sure I'm doing something wrong, but I don't understand where ...
    Does anyone know how to fix this problem?


    P.S.

    Other ports are configured the same:

      pic 1 {
           port 0 {
               speed 10g;
           }
           port 1 {
               speed 10g;
           }
           port 2 {
               speed 10g;                   
           }
           port 3 {
               speed 10g;
           }
           port 4 {
               speed 10g;
           }
           port 5 {
               speed 10g;
           }
           port 6 {
               speed 10g;
           }
           port 7 {
               speed 10g;
           }
       }



  • 2.  RE: MX204, unable to change port speed 40G/100G

    Posted 12-02-2020 10:10
    Hi TRFL,

    Your configuration looks correct, try to issue this command after commiting the configuration:

    request chassis pic pic-slot 0 fpc-slot 0 offline
    request chassis pic pic-slot 0 fpc-slot 0 online

    For MX204 and 10003 there is also Juniper Port Checker where you can check if your port/pic level configuration is correct.

    ------------------------------
    Regards,
    Elchin
    ------------------------------



  • 3.  RE: MX204, unable to change port speed 40G/100G

    Posted 12-02-2020 10:19

    Thank you!

    Your advice helped.