Junos OS

Expand all | Collapse all

Remote installation SRX320

  • 1.  Remote installation SRX320

    Posted 03-22-2021 15:41
    Good day,

    One of our customers abroad had a failed srx.
    tomorrow morning the replacement will be delivered.

    offcourse there is an option to use a machine with usb console etc... but i found: 
    Preparing the USB Flash Drive to Upgrade Junos OS - Technical Documentation - Support - Juniper Networks

    so i decided to give it a try,
    a new srx320 has firmware 15.1D180 (not exactly sure anymore but around this version)
    i created the usb with: 
    • a newer firmware (20.4R1.12)
    • a config file. (junos-config.conf)
    • and the autoinstall.conf file
    added the usb to the srx. light flash amber, pres reset, after a few seconds the lights stop flashing, around 20 minutes later the lights turn red.
    grabed the console cable and gave it another try.

    now something stranges happens.... it check the new firmware against the factory default. and fails.

    So the first question is why on earth does the process check against a config which it should replace during the upgrade? 


    so i added the firmware 15.1D230 to the stick and give it another go.
    this time everything looks prommising. and the leds turn green. but after a reboot it is still back to the factory config.

    so i was thinking what could go wrong?
    i created the file with windows notepad.... is that the problem?

    in the mean time it was time to go home.
    at home i have another srx320 with firmware 18.4R3-S2. and decided to give it another try.

    i downloaded an config from the "archival" server to make sure the file is exactly in the format the srx wanted.
    in the config file i sa it was last archived with firmware 15,1D230 wich was exactly the version i tried to install.

    place it in the srx. and started the upgrade.

    umass1: USB Disk 2.0, rev 2.00/2.00, addr 2
    da1 at umass-sim1 bus 1 target 0 lun 0
    da1: <VendorCo ProductCode 2.00> Removable Direct Access SCSI-4 device
    da1: 40.000MB/s transfers
    da1: 7680MB (15728640 512 byte sectors: 255H 63S/T 979C)
    Formatting alternate root (/dev/da0s1a)...
    /dev/da0s1a: 588.2MB (1204616 sectors) block size 16384, fragment size 2048
            using 4 cylinder groups of 147.06MB, 9412 blks, 18944 inodes.
    super-block backups (for fsck -b #) at:
     32, 301216, 602400, 903584
    Checking compatibility with configuration
    Initializing...
    Verified manifest signed by PackageProductionECP256_2020 method ECDSA256+SHA256
    Using junos-15.1X49-D230-domestic from /altroot/cf/packages/install-tmp/junos-15.1X49-D230-domestic
    Copying package ...
    Verified manifest signed by PackageProductionECP256_2020 method ECDSA256+SHA256
    Hardware Database regeneration succeeded
    Validating against /config/juniper.conf.gz
    Validation failed
    Validating against /config/rescue.conf.gz
    Validation failed
    ERROR: Configuration validation failed with /altroot/cf/packages/install-tmp/junos-15.1X49-D230-domestic
    ​

    Last change...
    Replaced the firmware with 18.4R3-S4.2 on the stick with (so it is compatible with the current config) and start the upgrade again.
    This time everything worked. 

    So you need to know the current firmware version of a brand new srx.
    You can't use notepad to create the config file.
    and the "out of the box" firmware must be compatible with the config you try to restore?

    can someone clear things out for me?

    Kind regards
    Mark


  • 2.  RE: Remote installation SRX320

    Posted 20 days ago
    Hi Koos,

    The configuration validation may fail if the current configuration is not compatible with the target Junos version. For example, a configuration statement that is supported in the Old Junos might not be supported in the newer Junos. Please note that you are not performing a Minor upgrade but rather a Major one from 15.1X49 train to 18.4R3. 

    Since you are trying USB auto-installation method to upgrade the Junos and trying to load the configuration automatically, I have no say in the matter as I never tried this one. I usually follow the USB Boot Loader installation using a USB storage which is efficient and later I will copy the configuration manually. 

    Installing Junos OS on SRX Series Devices from the Boot Loader Using a USB Storage Device - https://www.juniper.net/documentation/us/en/software/junos/junos-install-upgrade/topics/topic-map/install-software-on-srx.html

    ------------------------------
    ***𝑫𝒐 𝒎𝒂𝒓𝒌 𝒕𝒉𝒊𝒔 𝒂𝒏𝒔𝒘𝒆𝒓 𝒂𝒔 𝑺𝒐𝒍𝒗𝒆𝒅, 𝒊𝒇 𝒊𝒕 𝒂𝒅𝒅𝒓𝒆𝒔𝒔𝒆𝒔 𝒚𝒐𝒖𝒓 𝒊𝒔𝒔𝒖𝒆***

    𝕽𝖊𝖌𝖆𝖗𝖉𝖘,
    𝖓𝖔𝖔𝖇 𝖒𝖆𝖘𝖙𝖊𝖗.
    ------------------------------