Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  SRX300 Panic after inserting new USB 3.2 drive.

    Posted 08-26-2021 16:07
    Hello everyone. Several months ago, I purchased an SRX300 for a small office. I made several SnapShot copies during the setup process using two SanDisk Ultra Flair USB 3.0 Flash Drives. I recently purchased two smaller drives (16Gb), also SanDisk Ultra Flair USB 3.0, but when I plugged the first one in, it drove the system into panic and reboot.

    Comparing the two (FAT32) drives show slightly different versions.
    ->This drive does NOT work <-
    root@srx300% umass1: USB SanDisk 3.2Gen1, rev 3.20/1.00, add 2
    -> This drive does work <-
    root@srx300% umass1: SanDisk Ultra USB 3.0, rev 3.00/1.00, addr 2

    It appears the newest version of the Flair USB drive by SanDisk will not work at this time. Checking other brands, I find some are also at 3.2.

    I have one related question:

    After creating a USB SnapShot, what is the recommended procedure to remove the drive from the device? Does the request system snapshot process umount the drive when complete?

    ~~~~[ console output when drive inserted ]----
    root@srx300% umass1: USB SanDisk 3.2Gen1, rev 3.20/1.00, add 2
    (da1:umass-sim1:1:0:0): got CAM status 0x4
    (da1:umass-sim1:1:0:0): fatal error, failed to attach to device
    (da1:umass-sim1:1:0:0): lost device
    (da1:umass-sim1:1:0:0): removing device entry
    Opened disk da1 -> 6
    panic: umass1: Unknown state 1
    cpuid = 0
    KDB: stack backtrace:
    SP 0: not in kernel
    0+0x0 (0,0,0,0) ra 0 sz 0
    pid 45882, process: udev-sched-1.1
    Uptime: 6d4h42m10s
    Dumping 222 MB: 222 219 --->
    Automatic reboot in 15 seconds - press a key on the console to abort.

    ~~~~ [ console output when good/working drive inserted ]~~~~
    da1 at umasroot@srx300% umass1: SanDisk Ultra USB 3.0, rev 3.00/1.00, addr 2s-sim1 bus 1 target 0 lun 0
    da1: <SanDisk Ultra USB 3.0 1.00> Removable Direct Access SCSI-6 device
    da1: 80.000MB/s transfers
    da1: 118464MB (242614272 512 byte sectors: 255H 63S/T 15102C)
    ~~~~

    Thanks for any help

    ------------------------------
    Jay Falvey
    ------------------------------


  • 2.  RE: SRX300 Panic after inserting new USB 3.2 drive.

     
    Posted 08-27-2021 05:27
    Hi,
    I can't provide any help unfortunately but I'd suggest to have the "crash on USB stick insertion" being looked at by JTAC.
    Regards
    Ulf


  • 3.  RE: SRX300 Panic after inserting new USB 3.2 drive.

    Posted 08-29-2021 05:21
    Hi Ulf,

    Thanks for taking the time to reply, and I like your suggestion regarding the report title. I'll contact JTAC early next week.

    Regards,
    Jay

    ------------------------------
    Jay FALVEY
    ------------------------------



  • 4.  RE: SRX300 Panic after inserting new USB 3.2 drive.

     
    Posted 08-27-2021 05:49
    Juniper does maintain a database of known issues they call Problem Reports or PR for short.  It can be searched for public entries here.

    https://prsearch.juniper.net/InfoCenter/index?page=prsearch

    I don't see this particular issue logged publicly yet.  So either it is still under evaluation or has not yet been reported for review.  If it were here it would let you know what version of Junos is needed for the patched fixed version.

    As Ulf mentioned, you can raise an official support case to report this and make sure it is tracked and fixed in a future version.
    https://prsearch.juniper.net/InfoCenter/index?page=prsearch


    USB manual dismount is as follows
    root@% umount /var/tmp/usb
    root@% umass1: at uhub0 port 1 (addr 3) disconnected
    (da1:umass-sim1:1:0:0): lost device
    (da1:umass-sim1:1:0:0): removing device entry
    umass1: detached
    

    For the full set of manual command using usb see this kb article
    https://kb.juniper.net/InfoCenter/index?page=content&id=KB12880

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 5.  RE: SRX300 Panic after inserting new USB 3.2 drive.

    Posted 08-29-2021 05:21
    Hi Spuluka,
    Thanks for the valuable links. Juniper does provide copious documentation, which I have found to be very helpful.

    I failed to mention in my original post that I am using 20.4R2.7. I was also able to confirm that 19.4R3 reacts the same. I tried several scenarios today, and it appears that all traffic is lost once one of the USB 3.2 drive is inserted. The lights on the unit's face continue to flash normally until the unit goes into reboot. Leaving the drive inserted prevents the unit from rebooting, but my system rebooted normally once the USB 3.2 drive was removed.

    I'll contact JTAC the first of next week and see what they think.

    Thanks for your time and suggestions.
    Jay

    ------------------------------
    Jay FALVEY
    ------------------------------



  • 6.  RE: SRX300 Panic after inserting new USB 3.2 drive.

    Posted 09-24-2021 05:25
    Hi Guys,

    Same situation here with this USB SanDisk 3.2Gen1. This USB stick freezes the SRX300.
    JUNOS 20.3R1.8
    umass0: ATP Electronics ATP CG eUSB, rev 2.00/11.00, addr 2
    umass1: USB SanDisk 3.2Gen1, rev 3.20/1.00, addr 2
    Timecounter "mips" frequency 1200000000 Hz quality 0
    panic: umass1: Unknown state 1

    James, have you been able to obtain an answer from JTAC ?

    Thanks in advance,

    ------------------------------
    JEREMIE Rouzet
    ------------------------------



  • 7.  RE: SRX300 Panic after inserting new USB 3.2 drive.

    Posted 09-24-2021 11:10
    Hi Jeremie,
    I was able to open a case on 9/1/2021 under the title of "SRX300 crash on USB 3.2Gen 1 stick insertion". I do receive periodic updates but no apparent progress in identifying the issue yet. If you have a service contract, it might be helpful to contact JTAC and let them know you are also experiencing the same problem. You can reference case 2021-0901-310131. If you are like me and don't have a service contract, our options are limited.

    I recently updated the case with the following:

    I recently purchased additional USB memory sticks from Kingston and Verbatim that mentioned USB 3.2 in their specifications. Both sticks worked fine (no system panic), BUT neither reported USB 3.2Gen1 when inserted.

    > umass1: Kingston DataTraveler 3.0, rev 3.20/0.01, addr 2
    > umass1: Verbatim STORE N GO, rev 3.10/11.00, addr 2

    At this point, the new version of the "SanDisk Ultra Flair" is the only device I have found to causes a system panic.

    > umass1: USB SanDisk 3.2Gen1, rev 3.20/1.00, addr 2
    > panic: umass1: Unknown state 1

    The labeling of USB devices from the manufacturer makes it difficult to identify which devices to avoid.

    ------------------------------
    Jay Falvey
    ------------------------------



  • 8.  RE: SRX300 Panic after inserting new USB 3.2 drive.

     
    Posted 09-24-2021 19:32
    Thank you for keeping us updated.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 9.  RE: SRX300 Panic after inserting new USB 3.2 drive.

    Posted 3 days ago
    THANK YOU SO MUCH!
    This is absolutely true! Had the same problem with SanDisk's models Ultra Fit and Cruiser Fit.
    THANK YOU!

    ------------------------------
    NIKOLAY MARINOV
    ------------------------------