Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

DHCP server on QFX5100, can't make it work

Jump to Best Answer
  • 1.  DHCP server on QFX5100, can't make it work

    Posted 06-20-2021 06:53
    Hi community,

    What am I missing?

    Goal: provide connectivity to 2 x APC PDUs in rack.
    Ports are up, but DHCP bindings table is empty.

    Appreciate any input!

    Relevant configuration:

    version 17.4R2.4;
    system {
        services {
            dhcp-local-server {
                group DHCPUSERS {
                    interface irb.301;
                }
            }
        }
    }
    interfaces {
        ge-0/0/41 {
            description PDU1;
            unit 0 {
                family ethernet-switching {
                    vlan {
                        members DHCPSERVER;
                    }
                    filter {
                        input pdu_firewall;
                    }
                }
            }
        }
        ge-0/0/42 {
            description PDU2;
            unit 0 {
                family ethernet-switching {
                    vlan {
                        members DHCPSERVER;
                    }
                    filter {
                        input pdu_firewall;
                    }
                }
            }
        }
        irb {
            unit 301 {
                family inet {
                    address 10.0.242.241/29;
                }
            }
        }
    }
    access {
        address-assignment {
            pool DHCPPOOL {
                family inet {
                    network 10.0.242.240/29;
                    range RANGE1 {
                        low 10.0.242.245;
                        high 10.0.242.246;
                    }
                    dhcp-attributes {
                        name-server {
                            1.1.1.1;
                        }
                        router {
                            10.0.242.241;
                        }
                    }
                }
            }
        }
    }
    vlans {
        DHCPSERVER {
            vlan-id 301;
            l3-interface irb.301;
        }
    }
    ​


  • 2.  RE: DHCP server on QFX5100, can't make it work

     
    Posted 06-20-2021 12:31
    Can you post the filter? Does it work without the filter? What does show dhcp server statistics show?


  • 3.  RE: DHCP server on QFX5100, can't make it work

     
    Posted 06-20-2021 14:43
    Agree your basic configuration matches what is required.
    https://www.juniper.net/documentation/us/en/software/junos/dhcp/topics/topic-map/dhcp-server-configuration.html#id-configuring-a-switch-as-a-dhcp-server

    But what is in this filter?  And can you deactivate it for testing?
    pdu_firewall​


    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 4.  RE: DHCP server on QFX5100, can't make it work

    Posted 06-21-2021 10:03
    Appreciate the input!
    There is no change in behavior when I disable pdu_firewall.

    I managed to figure out the issue but still need help.

    The issue was caused by the fact that 10.0.242.240/29 is a more-specific part of a larger subnet 10.0.242.240/24 used in a different irb on the same switch. 
    The moment I replaced it with a fresh/unused subnet (192.168.x.x) everything works as expected.

    Is there a way to use the above /29 (a part of larger /24 block used in a separate irb)  without having to split the /24 into pieces? (/25 + /26 + /27 + /28 etc)
    I suspect that the answer to that is "no" :D ?


  • 5.  RE: DHCP server on QFX5100, can't make it work
    Best Answer

     
    Posted 06-21-2021 13:53
    Yes, you can create a new routing instance for the /29 irb and its DHCP server, and then import that route into the default routing table.


  • 6.  RE: DHCP server on QFX5100, can't make it work

    Posted 06-21-2021 21:59
    Fantastic, thank you!