Junos OS

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Routing-Instance no-Forward and MPLS traffic

    Posted 11-29-2021 05:33
    Hi
    I have a scenario for testing on JunOS and IOS XE. based on this scenario, The routing domain is divided on JMX  and MPLS is running all over the routers. (The following diagram shows the scenario. The configuration and outputs  were attached.)
    Now the point is everything works fine but something bothers me here.
    On JMX the interfaces inside of Instance are not shown as MPLS-enabled but MPLS traffic is passed over them without any issue.

    jcluser@vMX1> show mpls interface
    Interface State Administrative groups (x: extended)
    gr-0/0/10.10 Up <none>
    ge-0/0/0.23 Up <none>
    ge-0/0/0.32 Dn <none>

    jcluser@vMX1> show mpls interface instance OSPF2
    MPLS instance is not running


    This output shows interface ge-0/0/0.34 and ge-0/0/0.35 in Instance no-forward OSPF2 are not MPLS enabled. Also, MPLS ping from R05 to JMX returns F code:

    Core_CSR#ping mpls ipv4 10.234.247.3/32 source 10.234.247.5
    Sending 5, 72-byte MPLS Echos to 10.234.247.3/32,
    timeout is 2 seconds, send interval is 0 msec:

    Codes: '!' - success, 'Q' - request not sent, '.' - timeout,
    'L' - labeled output interface, 'B' - unlabeled output interface,
    'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
    'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
    'P' - no rx intf label prot, 'p' - premature termination of LSP,
    'R' - transit router, 'I' - unknown upstream index,
    'l' - Label switched with FEC change, 'd' - see DDMAP for return code,
    'X' - unknown return code, 'x' - return code 0

    Type escape sequence to abort.
    FFFFF
    Success rate is 0 percent (0/5)
    Total Time Elapsed 24 ms

    I must note again:
    1- everything works fine and the L2VPN sessions between have no issue from every router to every router.
    2- MPLS LDP ping from the routers inside of Instance OSPF2  to JMX fails. 
    3- MPLS LDP ping from the router inside Instance master to JMX works fine.
    4- Another way around always works fine and JMX can do MPLS LDP ping all routers without issue.
    5- This behavior can be seen in the attached text files.

    Would you please help me out?
    Thank you

    ------------------------------
    Ali Soltan
    ------------------------------

    Attachment(s)

    txt
    JMX_Output.txt   10 KB 1 version
    txt
    R01.txt   9 KB 1 version
    txt
    R04-Inside OSPF2.txt   5 KB 1 version
    txt
    R05-Inside OSPF2.txt   11 KB 1 version
    txt
    JMX_Config.txt   5 KB 1 version


  • 2.  RE: Routing-Instance no-Forward and MPLS traffic

    Posted 12-01-2021 05:45
    Hi
    Is there anyone who can guide me in this regard?
    Thank you

    ------------------------------
    Ali Soltan
    ------------------------------