Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Problem with transfer-on-commit option

  • 1.  Problem with transfer-on-commit option

    This message was posted by a user wishing to remain anonymous
    Posted 10-22-2021 08:48
    This message was posted by a user wishing to remain anonymous

    Hello,
    I have the transfer-on commit option configured on several switches.
    set system archival configuration transfer-on-commit

    In some switches, the option works fine.
    Oct 21 09:48:58 SW-01 mgd[12778]: UI_COMMIT_COMPLETED: commit complete
    Oct 21 09:49:47 SW-01 logger: transfer-file: Transferred /var/transfer/config/SW-01_20211021_074858_juniper.conf.gz

    In some logs I have the information "file not found".
    Oct 20 09:07:48 SW-02 mgd[20890]: UI_COMMIT_COMPLETED: commit complete
    Oct 20 09:08:15 SW-02 logger: transfer-file: file /var/transfer/config/SW-02_20210901_072011_juniper.conf.gz not found

    I noticed that the logger want transfer file with a different name than it should be. The name is related to the date. The date on the switches is correct. (Command show system uptime).
    In the directory  /var/transfer/config I found a configuration with the correct name.
    SW-02_20211020_070746_juniper.conf

    I don't know why the logger tries to copy files with the wrong name. thanks for the help in advance.