Junos OS

Help changing bootup partition - unable to revert to primary partition

  • 1.  Help changing bootup partition - unable to revert to primary partition

    Posted 22 days ago
      |   view attached
    Hi Community;

    I'm new to JUNOS and learning my way on an EX3300 with 12.3R12.4.   I've noticed my switch always boots from the backup partition, there are no alerts to indicate primary partition corruption and  I've done the snapshot repeatedly and tried to reboot from the alternate slice, but it always just boots off the backup slice. 

    root@EX3300> request system snapshot media internal slice alternate
    Formatting alternate root (/dev/da0s2a)...
    Copying '/dev/da0s1a' to '/dev/da0s2a' .. (this may take a few minutes)
    The following filesystems were archived: /

    root@EX3300> request system reboot media internal slice alternate
    Reboot the system ? [yes,no] (no) yes
    *** System shutdown message from root@EX3300 ***

    --> after reboot I log back in and check which partition i'm running on...

    root@EX3300>  show system storage partitions
    fpc0:
    --------------------------------------------------------------------------
    Boot Media: internal (da0)
    Active Partition: da0s2a
    Backup Partition: da0s1a
    Currently booted from: backup (da0s1a)

    I've turned auto-snapshot on just to get rid of the minor alert but it seems to not be able to get the switch to boot onto the primary partition either.  Any thoughts on why this is occurring or how to resolve?   using 12.3R12.4  Thanks.

    Attachment(s)

    txt
    ex3300_cli_log.txt   3 KB 1 version