Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Logical link between two reth interface.

    Posted 11-02-2021 08:12

    We have two reth interface.
    First is used for public ip  and second is used for LAN.

    root@SRX# show interfaces reth0
    vlan-tagging;
    redundant-ether-options {
    redundancy-group 1;
    }
    unit 0 {
    vlan-id 7777;
    family inet {
    address 7.7.7.7/29;
    }
    }

    root@SRX# show interfaces reth1
    description Link2EXCoreVC;
    vlan-tagging;
    redundant-ether-options {
    redundancy-group 2;
    lacp {
    passive;
    periodic slow;
    }
    }
    unit 111 {
    vlan-id 111;
    family inet {
    address 172.16.111.1/24;
    }
    }
    unit 122 {
    vlan-id 122;
    family inet {
    address 172.16.122.1/24;
    }
    }
    unit 133 {
    vlan-id 133;
    family inet {
    address 172.16.133.1/24;
    }
    }


    Is there any way to send vlan 7777 from reth0.0 as a next vlan to reth1.0?

    We want to put public ip to vcenter to run some of virtual machine as dmz with public ip (NAT unfortunately is immpossible).




  • 2.  RE: Logical link between two reth interface.

     
    Posted 11-03-2021 05:43
    To extend a vlan layer 2 across two interfaces you will need to configure the layer 3 as a virtual interface instead of one on the interface as you have here.

    Depending on which model of srx you have this is either a vlan.#  or irb.# interface where the # is a unit on the interface.  All your ip information is configured here and you add that interface and unit to the appropriate zone.

    You configure the units on both reth interfaces as layer two.

    Then under vlans you add the layer three and both lay​er two interfaces and assign the desired vlan id.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------