Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

Configuring a Load Balanced Uplink with VRRP on the other side

  • 1.  Configuring a Load Balanced Uplink with VRRP on the other side

    Posted 08-16-2021 09:06
    Can someone help me out with a configuration challenge?

    I've got two SMF fiber drops plugged into my EX2200-C. Only one of the uplink ports is active, but I'd like them both active for load balance but more importantly for redundancy in case of a failure. The second uplink appears to be entirely disabled, even if it's the only port with an active conection.

    My configuration today, for the uplink ports, is:

    MY PORT 0
    ge-0/1/0 { unit 0 { family ethernet-switching { port-mode access; } } }

    MY PORT 1
    ge-0/1/1 { unit 0 { family ethernet-switching { port-mode access; } } }

    The configuration of the ports on my Internet Service Provider's end are as follows:

    ISP PORT 0
    unit 0 {
        family inet {
            address X.X.X.2/28 {
                vrrp-group 1 {
                    virtual-address X.X.X.1;
                    priority 200;
                    preempt;
                    accept-data;
               }
            }
        }
    }

    ISP PORT 1
    unit 0 {
        family inet {
            address X.X.X.3/28 {
                vrrp-group 1 {
                    virtual-address X.X.X.1;
                    priority 100;
                    preempt;
                    accept-data;
                }
            }
        }
    }

    What configuration do you recommend for redundancy and/or load balance? How can I set up my EX-2200C to make nice with the ISP configuration?

    ------------------------------
    CHRIS MIHALICZ
    ------------------------------


  • 2.  RE: Configuring a Load Balanced Uplink with VRRP on the other side

     
    Posted 08-16-2021 14:39
    interfaces {
        ge-0/1/0 {
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    vlan {
                        members vlan100;
                    }
                }
            }
        }
        ge-0/1/1 {
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    vlan {
                        members vlan100;
                    }
                }
            }
        }
        irb {
            unit 100 {
                family inet {
                    address x.x.x.4/28;
                }
            }
        }
    }
    routing-options {
        static {
            route 0.0.0.0/0 next-hop x.x.x.1;
        }
    }
    vlans {
        vlan100 {
            vlan-id 100;
            l3-interface irb.100;
        }
    }
    ​