Junos OS

Expand all | Collapse all

Some Questions regarding GRE Tunnel on M960

Jump to Best Answer
  • 1.  Some Questions regarding GRE Tunnel on M960

    Posted 30 days ago

    Hi 

    Based on what I found on Documentations, there is no dedicated MPC/PIC for GRE tunnel(Same as the one on M Series) GRE tunnel will use Fabric Channel of the card.

    Now Consider this scenario:

    1- We have a MPC10-C Card which has 2x500Gbps Fabric. If I configure GRE tunnel on this card By default one fabric is used for GRE tunnel right?

    2- Can we limit this allocation of Fabric to for example 100Gbps?

    3- Should we use a physical port on the card which fabric is allocated for underlying link of GRE? I mean Can we connect the link to underlying network(Which GRE is configured up on it) to one card and Assign the Fabric From another card?

    4- Consider we need to have about 10xGRE connections. (I asked this before and Answer is using "Sub-Interfaces") I want to know can be configure GRE sub-interfaces with different source and destination?

    Thank you



    ------------------------------
    Alireza Soltanian
    ------------------------------



  • 2.  RE: Some Questions regarding GRE Tunnel on M960

     
    Posted 22 days ago

    The use of the fabric and allocation of size can not be controlled or configured.  Your only choice is which card will host the tunnel interfaces.

    The general recommendation is that the tunnel interfaces be hosted on one of the physical cards where the ingress or egress of the tunnel traffic will transit.  This offers the most efficient use of the fabric.

    You create sub-interfaces on tunnel interfaces with the same method you do on any of the physical interfaces.  Simply create the multiple unit numbers and the family for the interface with the assigned addresses.



    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 22 days ago

    Hi 

    Thank you for the answer.

     About sub-interfaces. Can we use different ip source and ip  destination or even routing instance for GRE  on each sub-interfaces? 

    In this method practically we can have many GRE TUNNELS

    Thank you

    Alireza



    ------------------------------
    Ali Soltan
    ------------------------------



  • 4.  RE: Some Questions regarding GRE Tunnel on M960

     
    Posted 21 days ago
    Yes, sub-interfaces on the gre can be configured with all the same options as other interfaces.  So you can change subnets, routing instances and any other options like CoS or filters too.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 5.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 21 days ago
    Hi
    Thank you for the answer. I have still concern about this scenario. Can we configure multiple sub-interfaces GRE in this manner:
    Several GRE sub-interfaces over one Main GRE interface and each one of them are created over same Source Interface(Same IP address you say) towards different Destination IP address. These destinations are reachable via different Routing-Instances(Not the Default Routing Instances )
    I will be honored if you answer this question
    Thank you

    ------------------------------
    Ali Soltan
    ------------------------------



  • 6.  RE: Some Questions regarding GRE Tunnel on M960

     
    Posted 20 days ago
    Several GRE sub-interfaces over one Main GRE interface and each one of them are created over same Source Interface(Same IP address you say) towards different Destination IP address. These destinations are reachable via different Routing-Instances(Not the Default Routing Instances )

    This is not how interfaces and sub-interfaces work.  
    The interface level is the physical media shared by all resources configured under it.
    The sub-interface is where the resources like an ip address, ethernet encapsulation or mpls encapsulation occurs.
    It is NOT possible to configured a sub-interface underneath another one.
    There is only this one level of hierarchy on the interface.
    You cannot configure the same ip address on multiple sub-interfaces in the same router, this will fail the commit checks.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 7.  RE: Some Questions regarding GRE Tunnel on M960

     
    Posted 20 days ago
    yes, you can do it.  It can be tricky but it is possible. 


    ## same tunnel source



    However, I am thinking that maybe what you really want to do (not knowing what your real use case or goal is) is this:


    ## same tunnel source

    BTW. What Steve mentioned about not being able to configure the same IP address on multiple logical interfaces or units is correct if you keep them in the same routing instance. If you place them in different routing instances, then it is ok. 

    Regards, 


    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 8.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 21 days ago
    Hi
    Thank you for the answer. I have still concern about this scenario. Can we configure multiple sub-interfaces GRE in this manner:
    Several GRE sub-interfaces over one Main GRE interface and each one of them are created over same Source Interface(Same IP address you say) towards different Destination IP address. These destinations are reachable via different Routing-Instances(Not the Default Routing Instances )
    I will be honored if you answer this question
    Thank you

    ------------------------------
    Ali Soltan
    ------------------------------



  • 9.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 22 days ago

    Hi 

    Another question is MPLS label switching supported in this case?

    Thank yoh



    ------------------------------
    Ali Soltan
    ------------------------------



  • 10.  RE: Some Questions regarding GRE Tunnel on M960

     
    Posted 20 days ago
    mpls configuration is only permitted on unit 0 of an interface that has this as the one and only unit number.  

    This is a valid use of gre interfaces you can see the details here.
    https://www.juniper.net/documentation/en_US/junos/topics/usage-guidelines/mpls-configuring-mpls-signaled-lsps-to-use-gre-tunnels.html

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 11.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 20 days ago
    Hi
    So based on what you said, following configuration is not valid on MX960:
    show configuration interfaces gr-0/0/0
    unit 232 {
    tunnel {
    source 10.7.124.242;
    destination 10.150.0.194;
    }
    family inet {
    mtu 1472;
    address 10.241.51.253/30;
    }
    family mpls;
    }
    unit 233 {
    tunnel {
    source 10.7.124.242;
    destination 10.201.12.33;
    }
    family inet {
    mtu 1472;
    address 10.241.51.249/30;
    }
    family mpls;
    }
    unit 800 {
    tunnel {
    source 110.7.124.242;
    destination 10.87.248.218;
    path-mtu-discovery;
    }
    family inet {
    mtu 1472;
    address 10.241.55.1/30;
    }
    family mpls;
    }
    This configuration was taken from a M320 with PIC-Tunnel
    Thank you

    ------------------------------
    Ali Soltan
    ------------------------------



  • 12.  RE: Some Questions regarding GRE Tunnel on M960

     
    Posted 20 days ago
    This configuration should work fine on MX.  

    Regards, 


    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 13.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 20 days ago
    Hi Yasmin
    Thank you for the update. Even the term family mpls on each unit? Does it work on MX960?

    ------------------------------
    Ali Soltan
    ------------------------------



  • 14.  RE: Some Questions regarding GRE Tunnel on M960
    Best Answer

     
    Posted 19 days ago
    yeap! should work.  

    Regards, 


    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 15.  RE: Some Questions regarding GRE Tunnel on M960

    Posted 16 days ago
    Hi
    Thank you for the Answer...

    ------------------------------
    Ali Soltan
    ------------------------------