Junos OS

Expand all | Collapse all

Disabled Interface Counters

Jump to Best Answer
  • 1.  Disabled Interface Counters

    Posted 06-06-2019 07:52

    Hey guys,

     

    i poste some Month ago a problem with the CPU Usage at qfx switches. As workarround i execute this command

    cprod -A fpc0 -c 'set dcbcm bcmshell "counter off"'

    But this disables interface counting on all interfaces. is there a way to undo this change ?

     

    Here is the old Topic

    https://forums.juniper.net/t5/Junos/FXPC-Process-Eating-CPU/m-p/394097



  • 2.  RE: Disabled Interface Counters
    Best Answer

    Posted 06-06-2019 08:20

    Good Day,

     

    To undo this change you need to clearly state parameters like Interval, PortBitMap like they were set before.

    I guess you did not read and save them before the change, so the easiest and solid workaround would be to reboot the switch in maintenance window.

     

    This should restore the device.



  • 3.  RE: Disabled Interface Counters

    Posted 06-06-2019 08:38

    Hello Deimos

     

    I thought so. So i will plan a reboot of the fpc. Thanks for the fast Answer.



  • 4.  RE: Disabled Interface Counters

     
    Posted 06-06-2019 08:41

    This is a bit complicated. Better to check with JTAC.

     

    A few things you can do

    1. Check current counter. You can get from a few devices with/without "counter off" being set 

    set dcbcm bcmshell "counter"

     

    2. Reset the counter. Here's just example 

    set dcbcm bcmshell "counter portbitmap=xe0-xe48"

    set dcbcm bcmshell "counter interval=1"

     

    But again, there's no undo or factory default kind of command



  • 5.  RE: Disabled Interface Counters

    Posted 06-17-2019 22:53

    We cannot turn on the counter from the last disabled point, however, we can reset it.

     

    Ideally, the settings can be read with the below command.

     

    too long# set dcbcm bcmshell "counter"

    HW (unit 0)
    Current settings:
    Interval=500000
    PortBitMap=0x00000000000000000000000000000000000001ffffffffffffffffffffffffff, cpu,xe
    DMA=True

     

    We can set this value by copy paste of this map.

    set dcbcm bcmshell "counter portbitmap=0x00000000000000000000000000000000000001ffffffffffffffffffffffffff"

     

    E.G:

    too long# set dcbcm bcmshell "counter"

    HW (unit 0)
    Current settings:
    Interval=500000
    PortBitMap=0x0000000000000000000000000000000000000003fffffffffffffffffffffffe, xe0-xe96
    DMA=True

     

    too long# ...0000000000000001ffffffffffffffffffffffffff"

    HW (unit 0)

    too long# set dcbcm bcmshell "counter"

    HW (unit 0)
    Current settings:
    Interval=500000
    PortBitMap=0x00000000000000000000000000000000000001ffffffffffffffffffffffffff, cpu,xe
    DMA=True

    too long#