Junos OS

Expand all | Collapse all

RE offline logs / but RE is online

Jump to Best Answer
  • 1.  RE offline logs / but RE is online

    Posted 10-23-2019 07:05

    Hello,

     

    The ODD thing is happening, i receive these logs:

    Fru Offline (jnxFruContentsIndex 9, jnxFruL1Index 2, jnxFruL2Index 0, jnxFruL3Index 0, jnxFruName Routing Engine 1, jnxFruType 6, jnxFruSlot 1, jnxFruOfflineReason 2, jnxFruLastPowerOff 0, jnxFruLastPowerOn 0)

     

    but when i look into >show routing-engine it never was offline.

    Model RE-S-1800x4
    Start time 2019-09-08 00:42:48 CEST
    Uptime 41 days, 1 hour, 8 minutes, 35 seconds
    Last reboot reason Router rebooted after a normal shutdown.
    Load averages: 1 minute 5 minute 15 minute
    0.60 0.39 0.28

     

    fxp0 was checked it didn't flap :

     

    Physical interface: fxp0, Enabled, Physical link is Up
    Interface index: 64, SNMP ifIndex: 1, Generation: 3
    Type: Ethernet, Link-level type: Ethernet, MTU: 1514, Clocking: Unspecified, Speed: 1000mbps
    Device flags : Present Running
    Interface flags: SNMP-Traps
    Link type : Full-Duplex
    Physical info : Unspecified
    Hold-times : Up 0 ms, Down 0 ms
    Damping : half-life: 0 sec, max-suppress: 0 sec, reuse: 0, suppress: 0, state: unsuppressed
    Alternate link address: Unspecified
    Last flapped : 2019-09-08 00:24:37 CEST (5w6d 01:26 ago)

     

    What can be the cause of that logs? how to solve the issue ?



  • 2.  RE: RE offline logs / but RE is online

     
    Posted 10-23-2019 07:51

    Hello,

     

    Can you please confirm what kind of Juniper device yo are refering to? Is it a dual RE device or a single RE?

    In case of dual RE system sometimes REs do not fail but the keepalive failure might have happen which will give wrong ideas about the backup RE status.

     

    Please share the logs right before the offline error. Also, complete "show chassis routing-engine" output

     

    PS: If my reply answers your question please accept it as solution, kudos are appreciated too!!

    Thanks

    Vishal



  • 3.  RE: RE offline logs / but RE is online

    Posted 10-24-2019 00:09

    hello,

    its a dual RE system.

    For some reason RE1 keepalives are lost and thats why RE0 is logging it as offline. Also there are no any more logs that indicate to a problem

     

    Oct 19 00:45:00 event = E_NO_IPC, state = master, param = 0x0x0
    Oct 19 00:45:00 currentAction = A_WARN1

    Oct 19 00:45:00 No response from the other routing engine for the last 2 seconds.

    Oct 19 00:45:00 Currentstate master NextState master reason_code 1
    Oct 19 00:45:00 new state = master
    Oct 19 00:45:00 vc master RE state change: in-synch -> initializing
    Oct 19 00:45:00 vc master RE append vc ext disabled
    Oct 19 00:45:00 send hello/REinfo packet
    Oct 19 00:45:00 slot:0 send RE_INFO
    Oct 19 00:45:06 event = E_ORE_B, state = master, param = 0x0xa021008
    Oct 19 00:45:06 currentAction = A_NOOP

    Oct 19 00:45:06 Currentstate master NextState master reason_code 1
    Oct 19 00:45:06 new state = master
    Oct 19 00:45:06 vc master RE state change: initializing -> synching
    Oct 19 00:45:06 vc master RE append vc ext enabled
    Oct 19 00:45:06 slot:0 send RE_INFO
    Oct 19 00:45:06 vc master RE recv backup RE vc data, mid=255 sn=ÿÿÿÿÿÿÿÿÿÿÿÿ slots=8
    Oct 19 00:45:06 vc master RE state change: synching -> in-synch



  • 4.  RE: RE offline logs / but RE is online
    Best Answer

     
    Posted 10-24-2019 01:12

    hi ,

     

    I think you got the answer for your question about the log message, 

     

    One of the reason could be CPU high condition in Master RE due to which it missed the keepalive from backup RE

     

    More details are availabe in the KB - https://kb.juniper.net/InfoCenter/index?page=content&id=KB27703&actp=METADATA

     

    Thank you

    Prabin

    Please accept the solution, if it answred your query

     



  • 5.  RE: RE offline logs / but RE is online

     
    Posted 10-23-2019 23:33

    hi,

     

    Could you please confirm if you are seeing keepalive loss log before FRU offline log,

     

    Please check if this KB helps you 

     

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB20849

     

    Thank you

    Prabin 

    Please accept my solution, if it resolved your query