Junos OS

Expand all | Collapse all

Direct route for ip-X/X/X link missing

Jump to Best Answer
  • 1.  Direct route for ip-X/X/X link missing

    Posted 03-04-2018 15:52

    Hi!

     

    Why does the following not install a route for 2001:1111:1111:1111::/64?

     

        ip-0/1/0 {
            unit 0 {
                tunnel {
                    source 123.123.123.123;
                    destination 111.111.111.111;
                }
                family inet6 {
                    mtu 1480;
                    address 2001:1111:1111:1111::2/64;
                }
            }
        }

    (nets anonymized)



  • 2.  RE: Direct route for ip-X/X/X link missing

    Posted 03-04-2018 18:06

    a quick question.

     

    is this vMX or mx?

     

    Do you have tunneling service enabled?

     

    Do you see ip interface in "show interface terse" ?

     

    labroot@mx480> show interfaces terse | match ip
    ip-3/0/10 up up
    ipip up up
    pip0 up up

    labroot@mx480>

    [edit interfaces]
    labroot@mx480# load merge terminal relative
    [Type ^D at a new line to end input]
    ip-3/0/10 {
    unit 0 {
    tunnel {
    source 123.123.123.123;
    destination 111.111.111.111;
    }
    family inet6 {
    mtu 1480;
    address 2001:1111:1111:1111::2/64;
    }
    }
    }
    load complete

    [edit interfaces]
    labroot@mx480# commit
    commit complete

    [edit interfaces]
    labroot@mx480# run show route 2001:1111:1111:1111::2

    inet6.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    2001:1111:1111:1111::2/128
    *[Local/0] 00:00:06
    Local via ip-3/0/10.0

    [edit interfaces]
    labroot@mx480#

     

     



  • 3.  RE: Direct route for ip-X/X/X link missing

    Posted 03-05-2018 01:23

    Hi!

    Thanks for your reply! I just noticed the interface is not up (not found).

    I will check if tunneling services are enabled, seems to be the problem.

    This is a MX104.

     

    Edit: Seems like we already activated the tunnel services:

        fpc 0 {
            pic 0 {
                tunnel-services {
                    bandwidth 10g;
                }
            }
        }

     

     

    Kind regards,

    Kevin



  • 4.  RE: Direct route for ip-X/X/X link missing
    Best Answer

    Posted 03-05-2018 01:36
    Hi,

    Are you sure your ip interface no is correct?

    When I enable tunneling-services for pic0, I get below interface.


    {master}[edit]
    labroot@jtac-mx104-r2008# run show interfaces terse | match ip
    ipip up up
    pip0 up up

    {master}[edit]
    labroot@jtac-mx104-r2008# activate chassis fpc 0 pic 0 tunnel-services

    {master}[edit]
    labroot@jtac-mx104-r2008# commit
    commit complete

    {master}[edit]
    labroot@jtac-mx104-r2008# run show interfaces terse | match ip
    ip-0/0/10 up up
    ipip up up
    pip0 up up

    {master}[edit]
    labroot@jtac-mx104-r2008#


  • 5.  RE: Direct route for ip-X/X/X link missing

    Posted 03-05-2018 01:42

    You are right. I just browsed the docs again and I must use ip-0/0/0.

    I thougt I am able to specify own devices like irb or ethernet interfaces.

    Now I have renamed my interface to ip-0/0/0 and the tunnel is up!