Junos OS

Expand all | Collapse all

Weird error log

Jump to Best Answer
  • 1.  Weird error log

    Posted 09-01-2017 08:39

    Hi 
    I received the error log recently. I try to google it, but can't find any clue. 

     

    Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[0] Invalid Speed[4699507019709153456]
    Sep 1 23:00:01 mx960-2 fpc0 ge-0/0/2: error=7 :xeth_an_set_rgmii_rate
    Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/0/2, err=7 :an_periodic_run
    Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[1] Invalid Speed[4699507019709153456]
    Sep 1 23:00:01 mx960-2 fpc0 ge-0/1/2: error=7 :xeth_an_set_rgmii_rate
    Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/1/2, err=7 :an_periodic_run
    Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[0] Invalid Speed[4699507019709153456]
    Sep 1 23:00:01 mx960-2 fpc0 ge-0/0/2: error=7 :xeth_an_set_rgmii_rate
    Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/0/2, err=7 :an_periodic_run
    Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[1] Invalid Speed[4699507019709153456]
    Sep 1 23:00:01 mx960-2 fpc0 ge-0/1/2: error=7 :xeth_an_set_rgmii_rate
    Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/1/2, err=7 :an_periodic_run
    Sep 1 23:00:02 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[0] Invalid Speed[4699507019709153456]
    Sep 1 23:00:02 mx960-2 fpc0 ge-0/0/2: error=7 :xeth_an_set_rgmii_rate
    Sep 1 23:00:02 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/0/2, err=7 :an_periodic_run
    Sep 1 23:00:02 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[1] Invalid Speed[4699507019709153456]
    Sep 1 23:00:02 mx960-2 fpc0 ge-0/1/2: error=7 :xeth_an_set_rgmii_rate



  • 2.  RE: Weird error log

    Posted 09-01-2017 13:15
    What config you have on ge-0/0/2?


  • 3.  RE: Weird error log

    Posted 09-01-2017 18:18

    general configuration, like other interface. the configuration run 2~3 years.

     

    show interfaces ge-0/0/2
    speed auto;
    link-mode full-duplex;
    gigether-options {
    auto-negotiation;
    }
    unit 0 {
    family inet {
    filter {
    input-list DEFAULT-ACL;
    }
    sampling {
    input;
    output;
    }
    address x.x.x.x/30;
    }
    }

     

    show interfaces ge-0/1/2
    speed auto;
    link-mode full-duplex;
    gigether-options {
    auto-negotiation;
    }
    unit 0 {
    family bridge {
    interface-mode access;
    vlan-id 16;
    }
    }



  • 4.  RE: Weird error log
    Best Answer

    Posted 09-01-2017 22:03

    It looks like interface is not calculating the speed. Please check the "show interface ge-0/0/2" and check in output for Speed.

    It seems to me that it is not calculating the speed because of the "speed auto" and "gigether-options auto-negotiation" knobs under the interface configuration. Please remove it and test

     

    [KUDOS PLEASE! If you think I earned it!

    If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]

     

     



  • 5.  RE: Weird error log

    Posted 09-20-2017 02:48

    Hi 
    thank your suggestion. after removing it then works.



  • 6.  RE: Weird error log

     
    Posted 09-15-2017 04:32

    I suspect the link is at half duplex check this in operational mode to get the link actual negociation status.

     

    show interfaces ge-0/0/2 media

     

    If it is half duplex the turn off auto-neg in configuration mode.  This will bounce the port so should be in a maintenance window.

     

    set interface ge-0/0/2 gigether-options no-auto-negotiation



  • 7.  RE: Weird error log

    Posted 09-13-2017 22:40

    You can always have a look on logs via "System log Explorer", below is the link to it:

     

    https://apps.juniper.net/syslog-explorer/

     

    P.S.: There might be a possibility that you dont find few of the logs in this tool.

     

     

    Furthermore, 

    Link to your error log:

     

    https://apps.juniper.net/syslog-explorer/#msg=CHASSISD_PIC_SPEED_INVALID&sw=Junos%20OS&rel=17.2R1