Junos OS

Expand all | Collapse all

"show interface <> detail" don't list all filters

Jump to Best Answer
  • 1.  "show interface <> detail" don't list all filters

    Posted 05-10-2020 02:02

    [Notice] This post is a non-issue at all.

     

    Hi:

    Interface doesn't list all filters, but only show up in alternating order.

     

    # Set ipv4 firewall filter to interface ae1
    =====================
    set firewall family inet filter ip4_sample term t1 then count ip4_sampling_count
    set firewall family inet filter ip4_sample term t1 then sample
    set interfaces ae1 unit 0 family inet filter input ip4_sample
    set interfaces ae1 unit 0 family inet filter output ip4_sample
    set forwarding-options sampling input rate 10  
    set forwarding-options sampling family inet output flow-server 192.168.0.1 port 1000
    
    # Set ipv6 firewall filter to interface ae1
    —————————————
    set firewall family inet6 filter ip6_sampling term t1 then count ip6_sampling_count
    set firewall family inet6 filter ip6_sampling term t1 then sample
    set forwarding-options sampling input rate 2000
    set forwarding-options sampling family inet6 output flow-server 192.168.0.2 port 1000 version9 template v6
    set forwarding-options sampling family inet6 output inline-jflow source-address 1.1.1.1
    set services flow-monitoring version9 template v6 ipv6-template
    set interfaces ae1 unit 0 family inet6 filter input ip6_sampling
    set interfaces ae1 unit 0 family inet6 filter output ip6_sampling
    

    When I do a "run show interface ae1 detail"; only 1 filter is shown up at a time instead of 2 filters shown up on interface "ae1".
    That is, filter "ip4_sample" was shown first, then about 10 seconds - 2 minutes later, "ip6_sampling" filter would be shown next; continued in this alternating fashion. Is that expected behaviour?

     

    admin@mx960# run show interfaces ae1 detail
    ......... Input Filters: ip4_sample Output Filters: ip4_sample
    admin@mx960# run show interfaces ae1 detail
    ......... Input Filters: ip6_sampling
    Output Filters: ip6_sampling

     



  • 2.  RE: "show interface <> detail" don't list all filters
    Best Answer

     
    Posted 05-10-2020 08:00

    Hello PL2,

     

    Greeting!

     

    I have dumped the same configuration on one of the lab devices and I was able to see both filters.  IPv4 sample and IPv6 Sampling.

     

    labroot@re0> show version
    Hostname: jtac-mx480-r2032-re0
    Model: mx480
    Junos: 19.1R1-S4.2

     

    [edit firewall family inet]
    labroot@re0# show
    filter ip4_sample {
    term t1 {
    then {
    count ip4_sampling_count;
    sample;
    }
    }
    }

    [edit firewall family inet6]
    labroot@re0# show
    filter ip6_sampling {
    term t1 {
    then {
    count ip6_sampling_count;
    sample;
    }
    }
    }

    [edit forwarding-options sampling]
    labroot@re0# show
    input {
    rate 2000;
    }
    family inet {
    output {
    flow-server 192.168.0.1 {
    port 1000;
    }
    }
    }
    family inet6 {
    output {
    flow-server 192.168.0.2 {
    port 1000;
    version9 {
    template {
    v6;
    }
    }
    }
    inline-jflow {
    source-address 1.1.1.1;
    }
    }
    }

    [edit interfaces ae0]
    labroot@re0# show
    aggregated-ether-options {
    lacp {
    active;
    }
    }
    unit 0 {
    family inet {
    filter {
    input ip4_sample;
    output ip4_sample;
    }
    address 1.1.1.1/32;
    }
    family inet6 {
    filter {
    input ip6_sampling;
    output ip6_sampling;
    }
    }
    }

     

    ---------------------------------------------------------------------------------------------

     

    Each iteration was taken after 30-40 seconds after the previous one:

     

    [edit]
    labroot@re0# run show interfaces ae0 detail |match filters
    Input Filters: ip4_sample
    Output Filters: ip4_sample
    Input Filters: ip6_sampling
    Output Filters: ip6_sampling

    [edit]
    labroot@re0# run show interfaces ae0 detail |match filters
    Input Filters: ip4_sample
    Output Filters: ip4_sample
    Input Filters: ip6_sampling
    Output Filters: ip6_sampling

    [edit]
    labroot@re0# run show interfaces ae0 detail |match filters
    Input Filters: ip4_sample
    Output Filters: ip4_sample
    Input Filters: ip6_sampling
    Output Filters: ip6_sampling


    labroot@re0# run show interfaces ae0 detail |match filters
    Input Filters: ip4_sample
    Output Filters: ip4_sample
    Input Filters: ip6_sampling
    Output Filters: ip6_sampling

    [edit]
    labroot@re0# run show interfaces ae0 detail |match filters
    Input Filters: ip4_sample
    Output Filters: ip4_sample
    Input Filters: ip6_sampling
    Output Filters: ip6_sampling

     

    Can you please tell me which version you are seeing the issue and on which device?

     

    I hope this helps. Please mark this post "Accept as solution" if this answers your query.

     

    Kudos are always appreciated! Smiley Happy

     

    Best Regards,

    Lingabasappa H

     

     



  • 3.  RE: "show interface <> detail" don't list all filters

    Posted 05-10-2020 19:23

    Sorry, both filters were there the whole time. I just missed seeing one of them.



  • 4.  RE: "show interface <> detail" don't list all filters

     
    Posted 05-10-2020 19:36

    Hello Pl2,

     

    Thanks for the confirmation. 

     

    Request you to mark the solution for the queries you post as accepted if it answered your query/queries.

    This would enable others to find the right solution for the same/similar queries on the forum.

     

    I hope this helps. Please mark my above post "Accept as solution" if that answers your query.

     

    Kudos are always appreciated! Smiley Happy

     

    Best Regards,

    Lingabasappa H



  • 5.  RE: "show interface <> detail" don't list all filters

     
    Posted 05-10-2020 09:53

    This doesn't look to be expected behavior. What platform and junos are you running? You may want to open a JTAC case to check if there's any underlaying issue or just simple display/cosmetic issue 



  • 6.  RE: "show interface <> detail" don't list all filters

    Posted 05-10-2020 19:22

    Sorry, both filters were there the whole time. I just missed one of them.