Junos OS

Expand all | Collapse all

BNG Lab on vMX 18.1

Jump to Best Answer
  • 1.  BNG Lab on vMX 18.1

    Posted 09-15-2020 00:45

    Hi everyone

    I am playing around with BNG feature on vMX 18.1, I have an issue during PPPoE discovery phase, which I receive "No resource"  error in PADS while I try to initiate PPPoE session from Windows 10 client.

    Without any boring text, I attached a diagram and vMX configuration.

    One question here, for test BNG on vMX do I need a license? since I am using free 60days trial license of vMX

    Best regards

    Alireza

    Attachment(s)

    pdf
    Virtual_Lab_v1.0.pdf   92K 1 version
    txt
    JunOS_config.txt   3K 1 version


  • 2.  RE: BNG Lab on vMX 18.1
    Best Answer

     
    Posted 09-15-2020 02:35

    Hello,

     

    I'd suggest using this configuration:

     

    set dynamic-profiles auto-stacked-vlan interfaces demux0 unit "$junos-interface-unit" no-traps
    set dynamic-profiles auto-stacked-vlan interfaces demux0 unit "$junos-interface-unit" vlan-tags outer "$junos-stacked-vlan-id"
    set dynamic-profiles auto-stacked-vlan interfaces demux0 unit "$junos-interface-unit" vlan-tags inner "$junos-vlan-id"
    set dynamic-profiles auto-stacked-vlan interfaces demux0 unit "$junos-interface-unit" demux-options underlying-interface "$junos-interface-ifd-name"
    set dynamic-profiles auto-stacked-vlan interfaces demux0 unit "$junos-interface-unit" family pppoe dynamic-profile prod-pppoe-base
    set dynamic-profiles prod-pppoe-base routing-instances "$junos-routing-instance" interface "$junos-interface-name"
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" no-traps
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" ppp-options chap
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" ppp-options pap
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" pppoe-options underlying-interface "$junos-underlying-interface"
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" pppoe-options server
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" keepalives interval 30
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" family inet rpf-check
    set dynamic-profiles prod-pppoe-base interfaces pp0 unit "$junos-interface-unit" family inet unnumbered-address "$junos-loopback-interface"
    
    set system dynamic-profile-options versioning
    set system services subscriber-management enable
    set system configuration-database max-db-size 314572800
    set chassis network-services enhanced-ip
    
    set interfaces ge-0/0/0 flexible-vlan-tagging
    set interfaces ge-0/0/0 auto-configure stacked-vlan-ranges dynamic-profile auto-stacked-vlan accept pppoe
    set interfaces ge-0/0/0 auto-configure stacked-vlan-ranges dynamic-profile auto-stacked-vlan ranges any,any
    set interfaces ge-0/0/0 auto-configure remove-when-no-subscribers

     

    But you'll have to delete your dynamic profiles first, commit, and then apply (probably you'll have to reboot vMX afterwards).

     

     

    Best regards,

    Sergii

    -------------------------------------------------------------------

    Please accept the solution if your problem is resolved Smiley Happy

    -------------------------------------------------------------------



  • 3.  RE: BNG Lab on vMX 18.1

    Posted 09-15-2020 03:23

    Dear Sergii

    I figured it out, the problem was I did not enable subscriber management on Virtual Image, Now the subscriber was connected 

    Thank you