Junos OS

Expand all | Collapse all

Additional MS-MPC-128G not being used by CGNAT

Jump to Best Answer
  • 1.  Additional MS-MPC-128G not being used by CGNAT

    Posted 03-21-2020 07:58

    Hello team:

    My customer´s MS-MPC card on slot 0 of the MX480 router was approaching 80% of CPU so he added another MS-MPC card in slot 3, in order to have more CGNAT resources.

     

    The original commands (the ones related to slot0´s card) were the following. The idea was to add the new card to the same CGNAT group "ams0":

     - set interfaces ams0 load-balancing-options member-interface mams-0/0/0
     - set interfaces ams0 load-balancing-options member-interface mams-0/1/0
     - set interfaces ams0 load-balancing-options member-interface mams-0/2/0
     - set interfaces ams0 load-balancing-options member-interface mams-0/3/0

     

    He brought the new card online with the "request chassis fpc slot 3 online" command, and then he added the following configuration commands:

     - set interfaces ams0 load-balancing-options member-interface mams-3/0/0
     - set interfaces ams0 load-balancing-options member-interface mams-3/1/0
     - set interfaces ams0 load-balancing-options member-interface mams-3/2/0
     - set interfaces ams0 load-balancing-options member-interface mams-3/3/0

     

    Result: half of the original sessions stopped working, and the new card did nothing useful. It seems as if the router schedules the sessions across both cards, but only the original one still processes the session whereas the new one does nothing.

     

    ¿ did we miss anything?

    Any hints will be greatly appreciated.

     

    Best regards, Rogelio (Argentina)

     

     



  • 2.  RE: Additional MS-MPC-128G not being used by CGNAT

    Posted 03-21-2020 08:30

    Solved!!

     

    It was enough with the "request chassis fpc slot 3 restart". Once executed, the sessions started to appear on the new card!!!!

     

    The old trick of resorting to the faithful "reset" command 🐵

     

    Thanks!

     

     

     

     



  • 3.  RE: Additional MS-MPC-128G not being used by CGNAT

     
    Posted 03-21-2020 08:40

    The new interfaces would also need to be added under the routing instance if one is used for the orginal interfaces.

     



  • 4.  RE: Additional MS-MPC-128G not being used by CGNAT

    Posted 03-26-2020 03:05

    Hello Steve.

    I will discuss your suggestion with the end user; I do not have a clear picture on whether the card was assigned or not to a routing instance. I do not think so.

    I will get back with a reply. Thanks!



  • 5.  RE: Additional MS-MPC-128G not being used by CGNAT
    Best Answer

    Posted 03-21-2020 20:42

    Hello,

     


    @ralvez wrote:

     

    ¿ did we miss anything?

     

    AFAIK, ON-THE-FLY addition of MAMS interfaces into AMS bundle is not supported.

    At least the deactivation/reactivation of the service-set via config is required.

    But it seems that You figured it out that MS-MPC reset also works.

    HTH

    Thx

    Alex