Junos OS

Expand all | Collapse all

cannot validate certs.pem

Jump to Best Answer
  • 1.  cannot validate certs.pem

    Posted 11-07-2017 09:18

    I am trying to update the software of a brand new EX4300 VC before it goes into production. The switches shipped with 13.2X51-D35.3 and I am trying to update to 14.1X53-D45.3.

    After the validation, the I get a signature error:

    Verify the signature of the new package
    verify-sig: cannot validate certs.pem
    certificate is not yet valid: /C=US/ST=CA/L=Sunnyvale/O=Juniper Networks/OU=Juniper CA/CN=PackageProductionRSA_2017/emailAddress=ca@juniper.net

    ERROR: Package signature validation failed. Aborting install.

     

    I verified the MD5 checksum, so I'm confident this isn't an issue with a corrupted download 



  • 2.  RE: cannot validate certs.pem
    Best Answer

    Posted 11-07-2017 19:31


  • 3.  RE: cannot validate certs.pem

    Posted 11-08-2017 04:55

    Clued into this yesterday, and got the software updated.

    Thx



  • 4.  RE: cannot validate certs.pem

    Posted 12-04-2017 13:12

    Use a "no-validate" to skip the date/time checks like shown below. It will work

    "request system software add /var/tmp/jinstall-ex-4300-14.1X53-D45.3-domestic.tgz no-validate"

    thanks