Junos OS

Expand all | Collapse all

pppoe on aggregated ethernet interfaces

Jump to Best Answer
  • 1.  pppoe on aggregated ethernet interfaces

    Posted 04-17-2019 04:34

    I'm trying to get pppoe subscriber management working on aggregated ethernet interfaces.

    On this so-called pppoe concentrator I have an ae interface with one member:

     

    xe-1/2/0 {
        gigether-options {
            802.3ad ae0;
        }
    }

     

    ae0 {
        description "CORE: core-nkh-01,ae8";
        flexible-vlan-tagging;
        native-vlan-id 1;
            remove-when-no-subscribers;
        }
        mtu 9192;
        encapsulation flexible-ethernet-services;
        aggregated-ether-options {
            lacp {
                active;
            }
        }
        unit 1 {
            vlan-id 1;
            family inet {
                mtu 1500;
                address xx.xx.xx.xx/yy;
            }
            family inet6 {
                mtu 1500;
            }
            family mpls;
        }
        unit 123 {
            vlan-id 123;
            family pppoe {
                dynamic-profile PPPoE-PROFILE-P;
            }
        }
    }

     

    This pppoe concentrator is connected to a CORE router of ours.

    It currently has the following EVPN configuration:

     

    TESTING-PPPoE {
        instance-type virtual-switch;
        route-distinguisher 202120L:12345;
        vrf-target target:202120L:12345;
        protocols {
            evpn {
                extended-vlan-list 123;
            }
        }
        bridge-domains {
            123 {
                vlan-id 123;
                interface ae8.123;
            }
        }
    }

    As well as on other routers needing to talk EVPN.

     

    On the subinterface ae0.123 I only see incoming packets, but not outgoing packets. Even not PADI packets.

    Once I switch outside the ae interface and just let pppoe packets come in on the xe-1/2/0 interface, I see all kinds of different pppoe packets.

     

    So my question is: does pppoe termination on ae interfaces work? If so, how would I accomplish that?

     

    Beeelze

     

     



  • 2.  RE: pppoe on aggregated ethernet interfaces
    Best Answer

     
    Posted 04-17-2019 04:44

    Hi, Please try below configuration.

     

    ae1 {
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    aggregated-ether-options {
    lacp {
    active;
    periodic fast;
    }
    }
    }
    demux0 {
    unit 100 {
    vlan-id 100;
    demux-options {
    underlying-interface ae1;
    }
    family pppoe {
    duplicate-protection;
    dynamic-profile PPPOE;
    }
    }



  • 3.  RE: pppoe on aggregated ethernet interfaces

    Posted 04-17-2019 05:25

    Hey Mayar,

     

    Great! That configuration seems to work!

    I should be able to manage the rest myself now.

     

    Thanks again.

     

    Beeelze



  • 4.  RE: pppoe on aggregated ethernet interfaces

    Posted 04-17-2019 05:48

    Strange, my MX routers never say anything about below parse error (Attr-Type: 13 = Framed-Compression).

     

    Apr 17 14:37:24.316 Parsing RADIUS message for session-id:7278

    Apr 17 14:37:24.316 radius-access-accept: Framed-Protocol received: 1

    Apr 17 14:37:24.317 RADIUS Attribute: Parse Error: "Unsupported attribute type" Radius Standard Attr-Type: 13

    Apr 17 14:37:24.317 radius-access-accept: Framed-IP-Address received: 185.52.209.160

    Apr 17 14:37:24.317 radius-access-accept: Framed-IP-Netmask received: 255.255.255.255

    Apr 17 14:37:24.317 radius-access-accept: Ingress-Policy-Name (Juniper-ERX-VSA) received: police-unlimited

    Apr 17 14:37:24.317 radius-access-accept: Egress-Policy-Name (Juniper-ERX-VSA) received: police-unlimited



  • 5.  RE: pppoe on aggregated ethernet interfaces

    Posted 01-18-2020 02:59

    Hello RNayar

     

    What if i am trying it to implement over dynamic subscribers with pp0 interface apart from demux interface

     

    set dynamic-profiles pppoe interfaces pp0 unit "$junos-interface-unit" ppp-options pap
    set dynamic-profiles pppoe interfaces pp0 unit "$junos-interface-unit" pppoe-options underlying-interface "$junos-underlying-interface"
    set dynamic-profiles pppoe interfaces pp0 unit "$junos-interface-unit" pppoe-options server
    set dynamic-profiles pppoe interfaces pp0 unit "$junos-interface-unit" keepalives interval 30
    set dynamic-profiles pppoe interfaces pp0 unit "$junos-interface-unit" family inet unnumbered-address lo0.0
    set dynamic-profiles pppoe interfaces pp0 unit "$junos-interface-unit" family inet6 unnumbered-address lo0.0

     

    And I am trying to add below units in ae interface only:

     

    set interfaces ae1 unit 1229 description AE-UNIT-1229
    set interfaces ae1 unit 1229 encapsulation ppp-over-ether
    set interfaces ae1 unit 1229 vlan-id 1229
    set interfaces ae1 unit 1229 pppoe-underlying-options duplicate-protection
    set interfaces ae1 unit 1229 pppoe-underlying-options dynamic-profile autopppoe
    set interfaces ae1 unit 1229 pppoe-underlying-options short-cycle-protection lockout-time-min 5
    set interfaces ae1 unit 1229 pppoe-underlying-options short-cycle-protection lockout-time-max 20

     

    What necessary changes needed to done , as i am facing same issue not receiving any subscriber packet (Including PADI).

     



  • 6.  RE: pppoe on aggregated ethernet interfaces

     
    Posted 01-20-2020 00:55

    Hello,

     

    Please create a new thread with your question and we'll try to help you there. Threads where the solution has already been found are not checked often (if checked at all).

     

    Best regards,

    Sergii