Junos OS

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Unable to add a new l2circuit

    Posted 10-12-2017 07:17

    Hello,

     

    I'm having a problem adding a new L2 circuit to my MX80 router.  I currently have 6 other pseudowires connected to other routers from this one, but trying to add another gives the error:

     

    [edit interfaces ge-1/1/2 unit 0]
    'family'
    Only the CCC family is allowed on CCC interfaces
    error: configuration check-out failed

     

    The config for the port is:

     

    ge-1/1/2 {
         encapsulation ethernet-ccc;
         unit 0 {
              family ccc;
         }
    }

    ....which is the same format as for the other pseudowires.

     

    If I remove 'unit 0' and 'family ccc' from the interface then it passes the commit check ok.

     

    The config for the l2circuit is:

     

    interface ge-1/1/2.0 {
        virtual-circuit-id 1010;
    }

    The box is running JunOS 13.3R8.7   - is there some kind of limit to the number of pseudowires that can be configured?

     

    Thanks for your help.

     

    Stuart



  • 2.  RE: Unable to add a new l2circuit
    Best Answer

    Posted 10-12-2017 07:45

    Found the problem.  There was some legacy config of:

     

    set groups inline-jflow interfaces <ge-1/1/*> unit <*> family inet sampling input

    which was being inherited and causing the problem.